summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-15 15:12:55 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-15 16:33:10 -0500
commit9d44234960f66517c854a51c9bfae3a856924ba5 (patch)
treeed95f34519d09cd9ee95947dbe11c68a05bd33b8
parent255fc0898df23b8fddbaeb283ed10d36af2efffd (diff)
downloadguix-patches-9d44234960f66517c854a51c9bfae3a856924ba5.tar
guix-patches-9d44234960f66517c854a51c9bfae3a856924ba5.tar.gz
gnu: Add python-libcst-minimal.
* gnu/packages/python-xyz.scm (python-libcst-minimal): New variable. (python-libcst): Add a tests? argument to the check phase override and strip trailing #t.
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 635d38fc91..eb7c040437 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13185,17 +13185,16 @@ some degree most natural languages too.")
(delete-file "libcst/tests/test_pyre_integration.py")
(delete-file "libcst/codemod/tests/test_codemod_cli.py")
(delete-file "libcst/metadata/tests/test_full_repo_manager.py")
- (delete-file "libcst/metadata/tests/test_type_inference_provider.py")
- #t))
+ (delete-file "libcst/metadata/tests/test_type_inference_provider.py")))
(add-before 'check 'generate-test-data
(lambda _
(setenv "PYTHONPATH" (string-append (getcwd) ":" (getenv "PYTHONPATH")))
(invoke "python" "-m" "libcst.codegen.generate" "visitors")
(invoke "python" "-m" "libcst.codegen.generate" "return_types")))
(replace 'check
- (lambda _
- (invoke "python" "-m" "unittest")
- #t)))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "unittest")))))))
(native-inputs
`(("python-black" ,python-black)
("python-isort" ,python-isort)))
@@ -13220,6 +13219,14 @@ feels like an AST.")
;; libcst/_add_slots.py
license:asl2.0))))
+(define-public python-libcst-minimal
+ (hidden-package
+ (package
+ (inherit python-libcst)
+ (name "python-libcst-minimal")
+ (arguments '(#:tests? #f))
+ (native-inputs '()))))
+
(define-public python-typing-inspect
(package
(name "python-typing-inspect")