summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-11 21:36:32 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-11 23:34:47 -0500
commit46ae78ba45711b43ca5948c9adbd23cc9e773bff (patch)
treec79585bbdf64fabce63be45f17405dd657e933b1
parent88e44f7e1615579cee27a08bcde31248e65c1178 (diff)
downloadguix-patches-46ae78ba45711b43ca5948c9adbd23cc9e773bff.tar
guix-patches-46ae78ba45711b43ca5948c9adbd23cc9e773bff.tar.gz
gnu: lean: Update to 3.41.0 and fixes toward cross-compilation.
* gnu/packages/lean.scm (lean): Update to 3.41.0. [phases]: Remove trailing #t. [tests?] Set to #false when cross-compiling. [inputs]: Add bash-minimal. Co-authored-by: Maxime Devos <maximedevos@telenet.be>
-rw-r--r--gnu/packages/lean.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/lean.scm b/gnu/packages/lean.scm
index 6ac7f1668a..646bd9597a 100644
--- a/gnu/packages/lean.scm
+++ b/gnu/packages/lean.scm
@@ -19,6 +19,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages lean)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages multiprecision)
#:use-module (guix build-system cmake)
#:use-module ((guix licenses) #:prefix license:)
@@ -28,7 +29,7 @@
(define-public lean
(package
(name "lean")
- (version "3.23.0")
+ (version "3.41.0")
(home-page "https://github.com/leanprover-community/lean")
(source (origin
(method git-fetch)
@@ -37,19 +38,19 @@
(file-name (git-file-name name version))
(sha256
(base32
- "09mklc1p6ms1jayg2f89hqfmhca3h5744lli936l38ypn1d00sxx"))))
+ "0mpxlfjq460x1vi3v6qzgjv74asg0qlhykd51pj347795x5b1hf1"))))
(build-system cmake-build-system)
(inputs
- (list gmp))
+ (list bash-minimal gmp))
(arguments
`(#:build-type "Release" ; default upstream build type
;; XXX: Test phases currently fail on 32-bit sytems.
;; Tests for those architectures have been temporarily
;; disabled, pending further investigation.
- #:tests? ,(let ((arch (or (%current-target-system)
- (%current-system))))
- (not (or (string-prefix? "i686" arch)
- (string-prefix? "armhf" arch))))
+ #:tests? ,(and (not (%current-target-system))
+ (let ((arch (%current-system)))
+ (not (or (string-prefix? "i686" arch)
+ (string-prefix? "armhf" arch)))))
#:phases
(modify-phases %standard-phases
(add-after 'patch-source-shebangs 'patch-tests-shebangs
@@ -62,10 +63,9 @@
(("#![[:blank:]]?/bin/bash")
(string-append "#!" bash))
(("#![[:blank:]]?usr/bin/env bash")
- (string-append "#!" bash)))
- #t)))
+ (string-append "#!" bash))))))
(add-before 'configure 'chdir-to-src
- (lambda _ (chdir "src") #t)))))
+ (lambda _ (chdir "src"))))))
(synopsis "Theorem prover and programming language")
(description
"Lean is a theorem prover and programming language with a small trusted