summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-12-10 22:54:06 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-12-12 00:03:48 +0530
commit1e52fd83c2f03f9fb3de9dde662bccd4407a9309 (patch)
tree6916612b0ab7468bc2ea7b9a7c5d9e9294a7a28c
parent42e891c27bccb32f51094c2c5cf85d5b4e5e6500 (diff)
downloadguix-patches-1e52fd83c2f03f9fb3de9dde662bccd4407a9309.tar
guix-patches-1e52fd83c2f03f9fb3de9dde662bccd4407a9309.tar.gz
gnu: Add afew.
* gnu/packages/mail.scm (afew): New variable.
-rw-r--r--gnu/packages/mail.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 21db463411..89062da3b7 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2381,3 +2381,28 @@ the GNOME desktop. It supports both POP3 and IMAP servers as well as the
mbox, maildir and mh local mailbox formats. Balsa also supports SMTP and/or
the use of a local MTA such as Sendmail.")
(license gpl3+)))
+
+(define-public afew
+ (package
+ (name "afew")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "afew" version))
+ (sha256
+ (base32
+ "121w7bd53xyibllxxbfykjj76n81kn1vgjqd22izyh67y8qyyk5r"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-chardet" ,python-chardet)
+ ("python-notmuch" ,python-notmuch)))
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)))
+ (home-page "https://github.com/afewmail/afew")
+ (synopsis "Initial tagging script for notmuch mail")
+ (description "afew is an initial tagging script for notmuch mail. It
+provides automatic tagging each time new mail is registered with notmuch. It
+can add tags based on email headers or Maildir folders and can handle spam and
+killed threads.")
+ (license isc)))