summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-08-19 19:02:05 +0200
committerLudovic Courtès <ludo@gnu.org>2013-08-20 00:57:24 +0200
commite858326a0f8574e98336046752a4bf786a2c1d0a (patch)
tree80dca99598da57c5d9df67caa2431cf0af9aaa07
parentba95e7028feaa3bf3b39da92dacf015a3d6690d0 (diff)
downloadguix-patches-e858326a0f8574e98336046752a4bf786a2c1d0a.tar
guix-patches-e858326a0f8574e98336046752a4bf786a2c1d0a.tar.gz
gnu: bigloo: Update to 4.0b.
* gnu/packages/scheme.scm (bigloo): Update to 4.0b. Patch the `configure-gc' scripts. Remove `patch-absolute-file-names' phase. * gnu/packages/patches/bigloo-gc-shebangs.patch: Adjust to new version.
-rw-r--r--gnu/packages/patches/bigloo-gc-shebangs.patch19
-rw-r--r--gnu/packages/scheme.scm37
2 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/patches/bigloo-gc-shebangs.patch b/gnu/packages/patches/bigloo-gc-shebangs.patch
index 07af261887..9ead2ba979 100644
--- a/gnu/packages/patches/bigloo-gc-shebangs.patch
+++ b/gnu/packages/patches/bigloo-gc-shebangs.patch
@@ -1,17 +1,18 @@
Patch shebangs in source that gets unpacked by `configure'.
---- bigloo3.9a/gc/install-gc-7.2d 2013-01-14 15:24:01.000000000 +0100
-+++ bigloo3.9a/gc/install-gc-7.2d 2013-01-14 15:23:51.000000000 +0100
-@@ -29,9 +29,11 @@ fi
+--- bigloo4.0b/gc/install-gc-7.3alpha3-20130330 2013-08-19 10:45:20.000000000 +0200
++++ bigloo4.0b/gc/install-gc-7.3alpha3-20130330 2013-08-19 10:46:36.000000000 +0200
+@@ -29,10 +29,12 @@ fi
+
# untar the two versions of the GC
$tar xfz $src -C ../gc || (echo "$tar xfz $src failed"; exit 1)
- /bin/rm -rf "../gc/$gc"_fth
-+find ../gc/gc-7.2 -perm /111 -type f | xargs sed -i -e"s|/bin/sh|`type -P bash`|g"
- mv ../gc/gc-7.2 "../gc/$gc"_fth || (echo "mv gc-7.2 failed"; exit 1)
+-/bin/rm -rf "../gc/$gc"_fth
++rm -rf "../gc/$gc"_fth
++find ../gc/$gc -perm /111 -type f | xargs sed -i -e"s|/bin/sh|`type -P sh`|g"
+ mv ../gc/$gc "../gc/$gc"_fth || (echo "mv $gc failed"; exit 1)
$tar xfz $src -C ../gc || (echo "$tar xfz $src failed"; exit 1)
-+find ../gc/gc-7.2 -perm /111 -type f | xargs sed -i -e"s|/bin/sh|`type -P bash`|g"
- mv ../gc/gc-7.2 "../gc/$gc"
++find ../gc/$gc -perm /111 -type f | xargs sed -i -e"s|/bin/sh|`type -P sh`|g"
# general Bigloo patch
-
+ (cd "../gc/$gc"_fth && $patch -p1 < ../$gc.patch > /dev/null)
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 4d717128d9..eb339d7236 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -118,14 +118,14 @@ development cycle.")
(define-public bigloo
(package
(name "bigloo")
- (version "4.0a")
+ (version "4.0b")
(source (origin
(method url-fetch)
(uri (string-append "ftp://ftp-sop.inria.fr/indes/fp/Bigloo/bigloo"
version ".tar.gz"))
(sha256
(base32
- "1771z43nmf9awjvlvrpjfhzcfxsbw2qipir8g9r47sygf2vn59yl"))))
+ "1fck2h48f0bvh8fl437cagmp0syfxy9lqacy1zwsis20fc76jvzi"))))
(build-system gnu-build-system)
(arguments
`(#:patches (list (assoc-ref %build-inputs "patch/shebangs"))
@@ -150,8 +150,14 @@ development cycle.")
"/lib/bigloo/" ,version)))
;; Those variables are used by libgc's `configure'.
- (setenv "SHELL" (which "bash"))
- (setenv "CONFIG_SHELL" (which "bash"))
+ (setenv "SHELL" (which "sh"))
+ (setenv "CONFIG_SHELL" (which "sh"))
+
+ ;; ... but they turned out to be overridden later, so work
+ ;; around that.
+ (substitute* (find-files "gc" "^configure-gc")
+ (("sh=/bin/sh")
+ (string-append "sh=" (which "sh"))))
;; The `configure' script doesn't understand options
;; of those of Autoconf.
@@ -162,21 +168,14 @@ development cycle.")
(string-append"--mv=" (which "mv"))
(string-append "--rm=" (which "rm"))))))
(alist-cons-after
- 'patch 'patch-absolute-file-names
- (lambda _
- (substitute* (cons "configure"
- (find-files "gc" "^install-gc"))
- (("/bin/rm") (which "rm"))
- (("/bin/mv") (which "mv"))))
- (alist-cons-after
- 'install 'install-emacs-modes
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (dir (string-append out "/share/emacs/site-lisp")))
- (zero? (system* "make" "-C" "bmacs" "all" "install"
- (string-append "EMACSBRAND=emacs24")
- (string-append "EMACSDIR=" dir)))))
- %standard-phases)))))
+ 'install 'install-emacs-modes
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (dir (string-append out "/share/emacs/site-lisp")))
+ (zero? (system* "make" "-C" "bmacs" "all" "install"
+ (string-append "EMACSBRAND=emacs24")
+ (string-append "EMACSDIR=" dir)))))
+ %standard-phases))))
(inputs
`(("emacs" ,emacs)
("patch/shebangs" ,(search-patch "bigloo-gc-shebangs.patch"))