summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-10-13 22:23:14 +0200
committerMarius Bakke <marius@gnu.org>2021-10-13 23:37:46 +0200
commit711ee48f81d62785b6e1fedcba20ed3078b8ab01 (patch)
treec9bd64786038ff0fda1be97ddb4c07a4e61d9a08
parent393315a98ef0b1cbafb661be5c36bbd4f30dba2e (diff)
downloadguix-patches-711ee48f81d62785b6e1fedcba20ed3078b8ab01.tar
guix-patches-711ee48f81d62785b6e1fedcba20ed3078b8ab01.tar.gz
gnu: ganeti: Prepare for Sphinx 4.0.
* gnu/packages/patches/ganeti-sphinx-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/virtualization.scm (ganeti)[source](patches): Add it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/ganeti-sphinx-compat.patch24
-rw-r--r--gnu/packages/virtualization.scm1
3 files changed, 26 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 6f037937ad..8c30eaafba 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1068,6 +1068,7 @@ dist_patch_DATA = \
%D%/packages/patches/ganeti-preserve-PYTHONPATH.patch \
%D%/packages/patches/ganeti-shepherd-master-failover.patch \
%D%/packages/patches/ganeti-shepherd-support.patch \
+ %D%/packages/patches/ganeti-sphinx-compat.patch \
%D%/packages/patches/gash-utils-ls-test.patch \
%D%/packages/patches/gawk-shell.patch \
%D%/packages/patches/gcc-arm-bug-71399.patch \
diff --git a/gnu/packages/patches/ganeti-sphinx-compat.patch b/gnu/packages/patches/ganeti-sphinx-compat.patch
new file mode 100644
index 0000000000..4e84abbf37
--- /dev/null
+++ b/gnu/packages/patches/ganeti-sphinx-compat.patch
@@ -0,0 +1,24 @@
+Adjust documentation for Sphinx 4.0.
+
+Discussed upstream at <https://github.com/ganeti/ganeti/pull/1615>.
+
+diff --git a/doc/index.rst b/doc/index.rst
+--- a/doc/index.rst
++++ b/doc/index.rst
+@@ -119,7 +119,6 @@ Draft designs
+ design-hotplug.rst
+ design-internal-shutdown.rst
+ design-kvmd.rst
+- design-location.rst
+ design-linuxha.rst
+ design-location.rst
+ design-lu-generated-jobs.rst
+diff --git a/lib/build/shell_example_lexer.py b/lib/build/shell_example_lexer.py
+--- a/lib/build/shell_example_lexer.py
++++ b/lib/build/shell_example_lexer.py
+@@ -79,4 +79,4 @@ class ShellExampleLexer(RegexLexer):
+
+
+ def setup(app):
+- app.add_lexer("shell-example", ShellExampleLexer())
++ app.add_lexer("shell-example", ShellExampleLexer)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 772a0ac430..0dd05a65c9 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -519,6 +519,7 @@ firmware blobs. You can
(file-name (git-file-name name version))
(patches (search-patches "ganeti-shepherd-support.patch"
"ganeti-shepherd-master-failover.patch"
+ "ganeti-sphinx-compat.patch"
"ganeti-haskell-compat.patch"
"ganeti-haskell-pythondir.patch"
"ganeti-disable-version-symlinks.patch"