summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-11-28 16:27:46 +0100
committerKei Kebreau <kkebreau@posteo.net>2020-12-07 16:08:41 -0500
commit476f19f57a3f3d9ab518829b4d6d341a92dfba81 (patch)
tree2ad5c011fcb6154168ba88578901c5330b9a40e0
parentd2ff5931ab7b3ee7db71c708305ff7c464908a30 (diff)
downloadguix-patches-476f19f57a3f3d9ab518829b4d6d341a92dfba81.tar
guix-patches-476f19f57a3f3d9ab518829b4d6d341a92dfba81.tar.gz
gnu: xfce4-whiskermenu-plugin: Fix installed shell script.
* gnu/packages/xfce.scm (xfce4-whiskermenu-plugin): Fix installed shell script. [arguments]: Add phase fix-shell-script to substitute paths to xfce4-panel and gettext. [inputs]: Add gettext-minimal. Co-authored-by: Kei Kebreau <kkebreau@posteo.net> Signed-off-by: Kei Kebreau <kkebreau@posteo.net>
-rw-r--r--gnu/packages/xfce.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 4090372805..dad7c1d03d 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -38,6 +38,7 @@
#:use-module (gnu packages cdrom)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gstreamer)
@@ -592,11 +593,21 @@ keys for controlling the audio volume.")
(inputs
`(("xfce4-panel" ,xfce4-panel)
("garcon" ,garcon)
+ ("gettext" ,gettext-minimal)
("exo" ,exo)
("gtk+" ,gtk+)
("libxfce4ui" ,libxfce4ui)))
(arguments
- `(#:tests? #f)) ; no tests
+ `(#:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-shell-script
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* (string-append "panel-plugin/xfce4-popup-whiskermenu.in")
+ (("@CMAKE_INSTALL_FULL_BINDIR@")
+ (string-append (assoc-ref inputs "xfce4-panel") "/bin"))
+ (("gettext") (which "gettext")))
+ #t)))))
(home-page "https://goodies.xfce.org/projects/panel-plugins/xfce4-whiskermenu-plugin")
(synopsis "Application menu panel plugin for Xfce")
(description