summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAllan Adair <allan@adair.no>2022-03-04 12:01:42 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-11 01:38:12 +0100
commitd4f6ea25251a5cf38e945278b790eda414c241b1 (patch)
tree4f95754a9bca5918510fb551112e399ddaa21bfc
parente2487db60272f148b7ab87ec2f13373b6a3a2134 (diff)
downloadguix-patches-d4f6ea25251a5cf38e945278b790eda414c241b1.tar
guix-patches-d4f6ea25251a5cf38e945278b790eda414c241b1.tar.gz
gnu: Add libxcrypt.
* gnu/packages/crypto.scm (libxcrypt): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/crypto.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index f07be01c97..0a7e401d54 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2021 Ellis Kenyő <me@elken.dev>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2022 Allan Adair <allan@adair.no>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -73,6 +74,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages python-check)
+ #:use-module (gnu packages python-crypto)
#:use-module (gnu packages readline)
#:use-module (gnu packages search)
#:use-module (gnu packages serialization)
@@ -1607,3 +1609,37 @@ checksum tool based on the BLAKE3 cryptographic hash function.")
;; Users may choose between these two licenses when redistributing the
;; program provided by this package.
(license (list license:cc0 license:asl2.0))))
+
+(define-public libxcrypt
+ (package
+ (name "libxcrypt")
+ (version "4.4.28")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/besser82/libxcrypt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pacj0s1hlv22iz0k2bkysjslc6rbrgmvmsr02qq17lp4d2gw5rs"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list autoconf
+ automake
+ libtool
+ perl
+ pkg-config
+ python-3
+ python-passlib))
+ (synopsis
+ "Extended crypt library for descrypt, md5crypt, bcrypt, and others")
+ (description
+ "libxcrypt is a modern library for one-way hashing of
+passwords. It supports a wide variety of both modern and historical
+hashing methods: yescrypt, gost-yescrypt, scrypt, bcrypt, sha512crypt,
+sha256crypt, md5crypt, SunMD5, sha1crypt, NT, bsdicrypt, bigcrypt, and
+descrypt.")
+ (home-page "https://github.com/besser82/libxcrypt")
+ (license license:lgpl2.1)))