summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-11 01:57:22 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-11 01:57:22 +0100
commitae85a472687c3987ceac7e8cd6f793b59dc75403 (patch)
treed457e8d05682030aa15f9483573fb6f406946224
parent5eeaf362f89d625c541cd32112bdd06a2471006d (diff)
downloadguix-patches-ae85a472687c3987ceac7e8cd6f793b59dc75403.tar
guix-patches-ae85a472687c3987ceac7e8cd6f793b59dc75403.tar.gz
gnu: xlockmore: Improve package style.
* gnu/packages/xdisorg.scm (xlockmore)[arguments]: Use G-expressions. [inputs]: Remove labels.
-rw-r--r--gnu/packages/xdisorg.scm35
1 files changed, 17 insertions, 18 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 4dc7817584..d2caee85ec 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1002,27 +1002,26 @@ shows it again when the mouse cursor moves or a mouse button is pressed.")
(name "xlockmore")
(version "5.68")
(source (origin
- (method url-fetch)
- (uri (list (string-append "http://sillycycle.com/xlock/"
- "xlockmore-" version ".tar.xz")
- ;; Previous releases are moved to a subdirectory.
- (string-append "http://sillycycle.com/xlock/"
- "recent-releases/"
- "xlockmore-" version ".tar.xz")))
- (sha256
- (base32
- "0vndfwccnvkaaraprjam8pmx0aj55va0ag64q6snxw83nbf1ywrh"))))
+ (method url-fetch)
+ (uri (list (string-append "http://sillycycle.com/xlock/"
+ "xlockmore-" version ".tar.xz")
+ ;; Previous releases are moved to a subdirectory.
+ (string-append "http://sillycycle.com/xlock/"
+ "recent-releases/"
+ "xlockmore-" version ".tar.xz")))
+ (sha256
+ (base32
+ "0vndfwccnvkaaraprjam8pmx0aj55va0ag64q6snxw83nbf1ywrh"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags (list (string-append "--enable-appdefaultdir="
- (assoc-ref %outputs "out")
- "/lib/X11/app-defaults"))
- #:tests? #f)) ;no such thing as a test suite
+ (list
+ #:configure-flags
+ #~(list (string-append "--enable-appdefaultdir="
+ #$output
+ "/lib/X11/app-defaults"))
+ #:tests? #f)) ;no such thing as a test suite
(inputs
- `(("libX11" ,libx11)
- ("libXext" ,libxext)
- ("libXt" ,libxt)
- ("linux-pam" ,linux-pam)))
+ (list libx11 libxext libxt linux-pam))
(home-page "https://sillycycle.com/xlockmore.html")
(synopsis "Screen locker for the X Window System")
(description