summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomás Ortín Fernández <tomasortin@mailbox.org>2020-10-04 16:58:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-10-07 21:52:44 +0200
commit5cdf77fd75e7dc4b81af325cd75ee1fe1b91b55a (patch)
treeeada1e767f370389557daa0730a46e42086b7c51
parent1ceeaa5dffe79d65b790e2f083adfbe01c84c064 (diff)
downloadguix-patches-5cdf77fd75e7dc4b81af325cd75ee1fe1b91b55a.tar
guix-patches-5cdf77fd75e7dc4b81af325cd75ee1fe1b91b55a.tar.gz
gnu: Add emacs-windsize.
* gnu/packages/emacs-xyz.scm (emacs-windsize): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8a9089faf1..99b6667bde 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -80,6 +80,7 @@
;;; Copyright © 2020 Peng Mei Yu <i@pengmeiyu.com>
;;; Copyright © 2020 Niklas Eklund <niklas.eklund@posteo.net>
;;; Copyright © 2020 Marco Grassi <marco.au.grassi98@protonmail.com>
+;;; Copyright © 2020 Tomás Ortín Fernández <tomasortin@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -7209,6 +7210,31 @@ called. If there are more, each window will have its first character
highlighted. Pressing that character will switch to that window.")
(license license:gpl3+)))
+(define-public emacs-windsize
+ ;; There is no proper release. The base version is extracted from the
+ ;; "Version" keyword in the main file.
+ (let ((revision "1")
+ (commit "62c2846bbe95b0a73e996c75e4a644d05f57aaaa"))
+ (package
+ (name "emacs-windsize")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/grammati/windsize")
+ (commit commit)))
+ (sha256
+ (base32 "13kfrmv3vmkfanxv9nym5v43hx5p7xkgqmx65zcxh4gcbaham1mi"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/grammati/windsize")
+ (synopsis "Easy resizing of Emacs windows")
+ (description
+ "This package allows moving the borders of the active window
+with the arrow keys. It prefers to move the right or bottom border when
+possible, and falls back to moving the left or top border otherwise.")
+ (license license:gpl3+))))
+
(define-public emacs-iedit
;; Last release version was in 2016.
(let ((commit "e2c100cdd67b7d82835d281ac2cd1bf4f374bc8f")