summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-10-16 23:25:55 +0200
committerLudovic Courtès <ludo@gnu.org>2021-10-16 23:25:55 +0200
commit258bbc4fdcc8a0538c9b151d5a8e82a82092a3cb (patch)
tree7fd9d960bedfecf2c7f87eaab8bf1eb6c228240f
parent1e631e46698289a7182b79e106507ad749f9ee55 (diff)
downloadguix-patches-258bbc4fdcc8a0538c9b151d5a8e82a82092a3cb.tar
guix-patches-258bbc4fdcc8a0538c9b151d5a8e82a82092a3cb.tar.gz
gnu: fakechroot: Update to PR #85 to build against glibc 2.33.
The latest release, 2.20.1, fails to build against glibc 2.33. Build the code submitted as pull request #85 instead of the latest release. * gnu/packages/linux.scm (fakechroot)[source]: Change to 'git-reference'. Use other source. [native-inputs]: New field.
-rw-r--r--gnu/packages/linux.scm52
1 files changed, 30 insertions, 22 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4e0b3ab2c4..9254b314a9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8052,34 +8052,42 @@ have to construct the archives directly, without using the archiver.")
(license license:gpl3+))))
(define-public fakechroot
- (package
- (name "fakechroot")
- (version "2.20.1")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/dex4er/fakechroot/releases/download/"
- version "/fakechroot-" version ".tar.gz"))
- (sha256
- (base32
- "1aijkd0b45wav25v01qhw8zxwa3pl0nnp9fabmmy1nlx7hr09gas"))))
- (build-system gnu-build-system)
- (arguments
- ;; XXX: The tests heavily assume they run on an FHS system so for now
- ;; skip them.
- '(#:tests? #f
- #:configure-flags '("--disable-static")))
- (synopsis "Emulate @code{chroot} by overriding file system calls")
- (description
- "@command{fakechroot} runs a command in an environment were is additional
+ ;; XXX: Build from the change submitted at
+ ;; <https://github.com/dex4er/fakechroot/pull/85> to allow compilation
+ ;; against glibc 2.33. Switch back to the official repository on the next
+ ;; release.
+ (let ((commit "e7c1f3a446e594a4d0cce5f5d499c9439ce1d5c5")
+ (revision "0"))
+ (package
+ (name "fakechroot")
+ (version (git-version "2.20.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lipnitsk/fakechroot")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0gac6a6djx3nf343vd33sr5qqngz8ss3aij54zl8x9wb47pc11kb"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; XXX: The tests heavily assume they run on an FHS system so for now
+ ;; skip them.
+ '(#:tests? #f
+ #:configure-flags '("--disable-static")))
+ (native-inputs (list autoconf automake libtool perl))
+ (synopsis "Emulate @code{chroot} by overriding file system calls")
+ (description
+ "@command{fakechroot} runs a command in an environment were is additional
possibility to use @code{chroot} command without root privileges. This is
useful for allowing users to create own chrooted environment with possibility
to install another packages without need for root privileges.
It works by providing @file{libfakechroot.so}, a shared library meant to be
set as @code{LD_PRELOAD} to override the C library file system functions.")
- (home-page "https://github.com/dex4er/fakechroot/")
- (license license:lgpl2.1+)))
+ (home-page "https://github.com/dex4er/fakechroot/")
+ (license license:lgpl2.1+))))
(define-public inputattach
(package