summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIvan Vilata i Balaguer <ivan@selidor.net>2022-03-07 00:47:07 +0100
committerLudovic Courtès <ludo@gnu.org>2022-03-11 23:07:22 +0100
commitdb41eabd47e676b3a08ff87ceea20e0cb9f98427 (patch)
tree0bce47c513b8ff7cc7b948cafd080ef8faa823f7
parent62fd3cf5b76cd4c5ce460704bcdd549c1f2077dd (diff)
downloadguix-patches-db41eabd47e676b3a08ff87ceea20e0cb9f98427.tar
guix-patches-db41eabd47e676b3a08ff87ceea20e0cb9f98427.tar.gz
gnu: transfig: Avoid "ar" option incompatibility with binutils 2.36.
Fixes <https://issues.guix.gnu.org/53425>. * gnu/packages/xfig.scm (transfig)[arguments]<#:phases>: Remove "l" option from "ar" invocation in makefiles to avoid incompatible meaning in binutils 2.36 causing error "ar: libdeps specified more than once". Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/xfig.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/xfig.scm b/gnu/packages/xfig.scm
index 9004c79e22..ad2f701ff1 100644
--- a/gnu/packages/xfig.scm
+++ b/gnu/packages/xfig.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2014 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2022 Ivan Vilata i Balaguer <ivan@selidor.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -123,6 +124,7 @@ selected in various ways. For text, 35 fonts are available.")
(invoke "xmkmf" "-a")
(substitute* '("Makefile"
"fig2dev/Makefile"
+ "fig2dev/dev/Makefile"
"transfig/Makefile")
;; These imake variables somehow remain undefined
(("DefaultGcc2[[:graph:]]*Opt") "-O2")
@@ -131,7 +133,12 @@ selected in various ways. For text, 35 fonts are available.")
(("(MANPATH = )[[:graph:]]*" _ front)
(string-append front out "/share/man"))
(("(CONFDIR = )([[:graph:]]*)" _ front default)
- (string-append front out default)))
+ (string-append front out default))
+ ;; The "l" option was silently ignored until binutils 2.36,
+ ;; where it got a different purpose. So remove it to avoid
+ ;; "ar: libdeps specified more than once".
+ (("((AR|MODAR) = ar )clq" _ front)
+ (string-append front "cq")))
#t)))
(add-after 'install 'install/doc
(lambda _