summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBird <birdsite@airmail.cc>2022-01-27 09:05:21 +0000
committerLudovic Courtès <ludo@gnu.org>2022-03-07 22:49:28 +0100
commitc723aa98b556a734fd8b463c5510eeb73d851c64 (patch)
tree96cd568fca51c596a39e33fdc105af48a621a849
parent1cad3476189d2ce84fabe95b69db8fb85a10b67a (diff)
downloadguix-patches-c723aa98b556a734fd8b463c5510eeb73d851c64.tar
guix-patches-c723aa98b556a734fd8b463c5510eeb73d851c64.tar.gz
gnu: Add gnusim8085.
* gnu/packages/emulators.scm (gnusim8085): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emulators.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 837b33fa6c..e31a7eda12 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -73,6 +73,7 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages libedit)
@@ -1944,6 +1945,42 @@ functions. The source code to MAME serves as this documentation.")
arcade and console emulator.")
(license license:gpl3+)))
+(define-public gnusim8085
+ (package
+ (name "gnusim8085")
+ (version "1.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/srid/GNUSim8085/releases/download/"
+ version "/gnusim8085-" version ".tar.gz"))
+ (sha256
+ (base32
+ "05x0is0ckagb3r74p6lw9b8nqrrh7q2v4jvc4cnhljchz9x7kw2a"))))
+ (native-inputs (list pkg-config))
+ (inputs (list gtksourceview-3 adwaita-icon-theme))
+ (build-system glib-or-gtk-build-system)
+ (home-page "https://gnusim8085.srid.ca")
+ (synopsis "Graphical simulator for the Intel 8085 microprocessor")
+ (description
+ "GNUSim8085 is a graphical simulator,
+assembler, and debugger for the Intel 8085 microprocessor.
+
+@itemize
+@item A simple editor component with syntax highlighting.
+@item A keypad to input assembly language instructions with appropriate arguments.
+@item Easy view of register contents.
+@item Easy view of flag contents.
+@item Hexadecimal/decimal converter.
+@item View of stack, memory and I/O contents.
+@item Support for breakpoints for program debugging.
+@item Stepwise program execution.
+@item One click conversion of assembly program to opcode listing.
+@item Printing support.
+@item UI translated in various languages.
+@end itemize")
+ (license license:gpl2+)))
+
(define-public pcsxr
;; No release since 2017.
(let ((commit "6484236cb0281e8040ff6c8078c87899a3407534"))