summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-02-19 16:03:37 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-03-08 20:53:43 +0100
commit4f82f343093a8509d476e422fcfae2b3c7908017 (patch)
treeb5f00495ab1c752f9e59e603db1e74559dabf761
parent59001c4f9156139ca86b3b067d8b04e88f280972 (diff)
downloadguix-patches-4f82f343093a8509d476e422fcfae2b3c7908017.tar
guix-patches-4f82f343093a8509d476e422fcfae2b3c7908017.tar.gz
gnu: Add poco.
* gnu/packages/cpp.scm (poco): New variable.
-rw-r--r--gnu/packages/cpp.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index b8a0a1b20b..eb53f9e0a9 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1126,6 +1126,39 @@ of C++14 components that complements @code{std} and Boost.")
(supported-systems '("aarch64-linux" "x86_64-linux"))
(license license:asl2.0)))
+(define-public poco
+ (package
+ (name "poco")
+ (version "1.11.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pocoproject/poco")
+ (commit (string-append "poco-" version "-release"))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qkf8vb4qwds6idk9fkw6wjvcdk5k8h77x3gv47l0i4jfl5hwn8b"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:configure-flags #~(list "-DENABLE_TESTS=ON")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-problematic-tests
+ (lambda _
+ (substitute* (list "Foundation/CMakeLists.txt" ; XXX: fails.
+ ;; Require network access
+ "Net/CMakeLists.txt"
+ "MongoDB/CMakeLists.txt"
+ "Redis/CMakeLists.txt")
+ (("ENABLE_TESTS") "FALSE")))))))
+ (home-page "https://pocoproject.org/")
+ (synopsis "Portable C++ components")
+ (description "A collection of libraries intended to be useful for building
+network-based applications.")
+ (license license:boost1.0)))
+
(define-public aws-crt-cpp
(let* ((commit "b6d311d76b504bf8ace5134d3fca0e672c36c9c3")
(revision "1"))