summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2017-01-04 16:25:20 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-01-06 16:31:14 +0100
commitd407bdb9318aa56ed2e0ffe520fa606a84568b01 (patch)
tree534912e8c5a51612585523273bdd5e422541fb2d
parent6193563a3648ae1732aa10939c8e9bf1b7e3a71d (diff)
downloadguix-patches-d407bdb9318aa56ed2e0ffe520fa606a84568b01.tar
guix-patches-d407bdb9318aa56ed2e0ffe520fa606a84568b01.tar.gz
gnu: Add r-copyhelper.
* gnu/packages/bioinformatics.scm (r-copyhelper): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 98d9f92e37..35269f8071 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7894,3 +7894,29 @@ common bioinformatics tools.")
"This package provides tools for processing short read data from ChIPseq
experiments.")
(license license:artistic2.0)))
+
+(define-public r-copyhelper
+ (package
+ (name "r-copyhelper")
+ (version "1.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://bioconductor.org/packages/release/"
+ "data/experiment/src/contrib/CopyhelpeR_"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0x7cyynjmxls9as2gg0iyp9x5fpalxmdjq914ss7i84i9zyk5bhq"))))
+ (properties `((upstream-name . "CopyhelpeR")))
+ (build-system r-build-system)
+ (home-page "http://bioconductor.org/packages/CopyhelpeR/")
+ (synopsis "Helper files for CopywriteR")
+ (description
+ "This package contains the helper files that are required to run the
+Bioconductor package CopywriteR. It contains pre-assembled 1kb bin GC-content
+and mappability files for the reference genomes hg18, hg19, hg38, mm9 and
+mm10. In addition, it contains a blacklist filter to remove regions that
+display copy number variation. Files are stored as GRanges objects from the
+GenomicRanges Bioconductor package.")
+ (license license:gpl2)))