summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorАлексей Дроздов <drozdov@portalenergy.tech>2022-01-21 14:00:08 +0300
committerLudovic Courtès <ludo@gnu.org>2022-03-06 22:49:48 +0100
commitafb9f2752315f131e4ddd44eba02eed403365085 (patch)
treee9b62606cba90bc727e5fa03bdbfade2f6efab60
parentd3fb8036b78ccdd8b14f386b4a5c50ce42f93f78 (diff)
downloadguix-patches-afb9f2752315f131e4ddd44eba02eed403365085.tar
guix-patches-afb9f2752315f131e4ddd44eba02eed403365085.tar.gz
gnu: Add python-xmldiff.
* gnu/packages/python-xyz.scm (python-xmldiff): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8b51bfb3d1..38659e3209 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -117,6 +117,7 @@
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
+;;; Copyright © 2022 drozdov <drozdov@portalenergy.tech>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -242,6 +243,24 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26))
+(define-public python-xmldiff
+ (package
+ (name "python-xmldiff")
+ (version "2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "xmldiff" version))
+ (sha256
+ (base32 "0qygxi3z1jwb0471k7bh5gcqf7wqm4xhrkmwhf36gjgjw46a5gh5"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-lxml python-six))
+ (home-page "https://github.com/Shoobx/xmldiff")
+ (synopsis "Creates diffs of XML files")
+ (description "This Python tool figures out the differences between two
+similar XML files, in the same way the @command{diff} utility does it.")
+ (license license:expat)))
+
(define-public python-janus
(package
(name "python-janus")