summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-09-23 03:38:02 +0000
committerLudovic Courtès <ludo@gnu.org>2021-10-02 17:23:11 +0200
commit62a24dd9a125095362789dd4b3c3fe3fd650f017 (patch)
tree7a315dd7408a3a42a10b9c589e6a8e34db6f2164
parentae1c206b26930038f3c69bd47d977ddb2554739e (diff)
downloadguix-patches-62a24dd9a125095362789dd4b3c3fe3fd650f017.tar
guix-patches-62a24dd9a125095362789dd4b3c3fe3fd650f017.tar.gz
gnu: gthumb: Add optional dependencies.
* gnu/packages/gnome.scm (gthumb)[native-inputs]: Order alphabetically. [inputs]: Order alphabetically. Add colord, libheif, librsvg, libwebp. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gnome.scm22
1 files changed, 13 insertions, 9 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0d0b57afcf..2d50ada1e4 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10877,23 +10877,27 @@ functionality.")
(assoc-ref %outputs "out")
"/lib/gthumb/extensions"))))
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
("glib:bin" ,glib "bin") ; for glib-compile-resources
("gtk+:bin" ,gtk+ "bin") ; for gtk-update-icon-cache
- ("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
("intltool" ,intltool)
- ("itstool" ,itstool)))
+ ("itstool" ,itstool)
+ ("pkg-config" ,pkg-config)))
(inputs
- `(("exiv2" ,exiv2)
- ("gtk" ,gtk+)
- ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("gstreamer" ,gstreamer)
- ("clutter" ,clutter)
+ `(("clutter" ,clutter)
("clutter-gst" ,clutter-gst)
("clutter-gtk" ,clutter-gtk)
+ ("colord" ,colord)
+ ("exiv2" ,exiv2)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gstreamer" ,gstreamer)
+ ("gtk" ,gtk+)
+ ("libheif" ,libheif)
("libjpeg" ,libjpeg-turbo)
+ ("libraw" ,libraw)
+ ("librsvg" ,librsvg)
("libtiff" ,libtiff)
- ("libraw" ,libraw)))
+ ("libwebp" ,libwebp)))
(home-page "https://wiki.gnome.org/Apps/Gthumb")
(synopsis "GNOME image viewer and browser")
(description "GThumb is an image viewer, browser, organizer, editor and