summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-06-02 23:08:33 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-05 13:41:42 +0200
commit612e5b8528e1f4f9c1c03ba7fa01997ca16f4250 (patch)
tree7fd8fc9493be168fda2a683c171b55ce2b81cfe7
parentbbf54272c6eb7da5ba2b072bc93ddc0928e87208 (diff)
downloadguix-patches-612e5b8528e1f4f9c1c03ba7fa01997ca16f4250.tar
guix-patches-612e5b8528e1f4f9c1c03ba7fa01997ca16f4250.tar.gz
gnu: Add emacs-hg-histedit.
* gnu/packages/emacs-xyz.scm (emacs-hg-histedit): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 704d9c9fb0..63de8bea05 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -506,6 +506,32 @@ outlines, manage all your contacts, your windows and frames, and search across
buffers, directory trees, or the web.")
(license license:gpl3+)))
+(define-public emacs-hg-histedit
+ ;; From 2021-03-02.
+ ;; No releases available.
+ (let ((commit "a05149483b9c5f7848ece0ba6028c900595a6a25")
+ (revision "0"))
+ (package
+ (name "emacs-hg-histedit")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jojojames/hg-histedit")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "04zps0d4s99f5a8ahrpyf8b6qw0c1y7rd1bsaq9nc6m4qblsvwc8"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-with-editor" ,emacs-with-editor)))
+ (home-page "https://github.com/jojojames/hg-histedit")
+ (synopsis "Emacs interface to @command{hg histedit}")
+ (description "This package provides an Emacs interface to
+@command{hg histedit} for editing the commit history.")
+ (license license:gpl3+))))
+
(define-public emacs-paredit
(package
(name "emacs-paredit")