summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-03-07 22:36:08 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-03-07 22:53:26 +0200
commit58e3a917e392f412dcc1088c3779fd9f5b7fb63c (patch)
tree875b5e032b9b586299048628e0fd497117951484
parentf80034c1ffca38324fdb669c9bd3fe9787a2efb2 (diff)
downloadguix-patches-58e3a917e392f412dcc1088c3779fd9f5b7fb63c.tar
guix-patches-58e3a917e392f412dcc1088c3779fd9f5b7fb63c.tar.gz
gnu: libxrender: Fix cross compiling to riscv64-linux.
* gnu/packages/xorg.scm (libxrender)[arguments]: When cross compiling to riscv64-linux replace config.sub and config.guess with newer versions. [native-inputs]: When cross compiling to riscv64-linux add config.
-rw-r--r--gnu/packages/xorg.scm22
1 files changed, 19 insertions, 3 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 14e35d19ae..14cd3bc789 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2015 Cyrill Schenkel <cyrill.schenkel@gmail.com>
-;;; Copyright © 2016, 2017, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Nikita <nikita@n0.is>
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
@@ -4754,13 +4754,29 @@ cannot be adequately worked around on the client side of the wire.")
(build-system gnu-build-system)
(arguments
`(#:configure-flags
- (list "--disable-static" ,@(malloc0-flags))))
+ (list "--disable-static" ,@(malloc0-flags))
+ ,@(if (and (%current-target-system)
+ (target-riscv64?))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'update-config
+ (lambda* (#:key native-inputs #:allow-other-keys)
+ (install-file
+ (search-input-file native-inputs "/bin/config.sub") ".")
+ (install-file
+ (search-input-file native-inputs "/bin/config.guess") ".")))))
+ '())))
(propagated-inputs
(list xorgproto))
(inputs
(list libx11))
(native-inputs
- (list pkg-config))
+ (append
+ (if (and (%current-target-system)
+ (target-riscv64?))
+ (list config)
+ '())
+ (list pkg-config)))
(home-page "https://www.x.org/wiki/")
(synopsis "Xorg Render Extension library")
(description "Library for the Render Extension to the X11 protocol.")