summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-03-26 19:16:29 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-02 00:59:53 -0400
commit50ca41ad707de7b525c6cc40c22dc60751b0f274 (patch)
tree520be2f68db32d1a63418c61915b2455c24d6d9f
parent7ba5ce94470847e7ec0f7c8b49432c1d0017dfb7 (diff)
downloadguix-patches-50ca41ad707de7b525c6cc40c22dc60751b0f274.tar
guix-patches-50ca41ad707de7b525c6cc40c22dc60751b0f274.tar.gz
gnu: Move libgme to audio.scm.
* gnu/packages/music.scm (libgme): Move from here... * gnu/packages/audio.scm (libgme): ... to here. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/audio.scm44
-rw-r--r--gnu/packages/music.scm44
2 files changed, 44 insertions, 44 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index b746cd370d..690c31074d 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -302,6 +302,50 @@ Linux kernel.")
(home-page "https://github.com/tinyalsa/tinyalsa")
(license (license:non-copyleft "file:///NOTICE"))))
+(define-public libgme
+ (package
+ (name "libgme")
+ (version "0.6.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://bitbucket.org/mpyne/game-music-emu/"
+ "downloads/game-music-emu-" version
+ ".tar.xz"))
+ (sha256
+ (base32
+ "07857vdkak306d9s5g6fhmjyxk7vijzjhkmqb15s7ihfxx9lx8xb"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f)) ; no check target
+ (home-page "https://bitbucket.org/mpyne/game-music-emu")
+ (synopsis "Video game music file playback library")
+ (description
+ "Game-music-emu is a collection of video game music file emulators that
+support the following formats and systems:
+@table @code
+@item AY
+ZX Spectrum/Asmtrad CPC
+@item GBS
+Nintendo Game Boy
+@item GYM
+Sega Genesis/Mega Drive
+@item HES
+NEC TurboGrafx-16/PC Engine
+@item KSS
+MSX Home Computer/other Z80 systems (doesn't support FM sound)
+@item NSF/NSFE
+Nintendo NES/Famicom (with VRC 6, Namco 106, and FME-7 sound)
+@item SAP
+Atari systems using POKEY sound chip
+@item SPC
+Super Nintendo/Super Famicom
+@item VGM/VGZ
+Sega Master System/Mark III, Sega Genesis/Mega Drive, BBC Micro
+@end table")
+ (license (list license:lgpl2.1+
+ ;; demo and player directories are under the Expat license
+ license:expat))))
+
(define-public libopenmpt
(package
(name "libopenmpt")
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ae4626dc8a..d022dccd35 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1320,50 +1320,6 @@ for path in [path for path in sys.path if 'site-packages' in path]: site.addsite
interface. It is implemented as a frontend to @code{klick}.")
(license license:gpl2+)))
-(define-public libgme
- (package
- (name "libgme")
- (version "0.6.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://bitbucket.org/mpyne/game-music-emu/"
- "downloads/game-music-emu-" version
- ".tar.xz"))
- (sha256
- (base32
- "07857vdkak306d9s5g6fhmjyxk7vijzjhkmqb15s7ihfxx9lx8xb"))))
- (build-system cmake-build-system)
- (arguments
- '(#:tests? #f)) ; no check target
- (home-page "https://bitbucket.org/mpyne/game-music-emu")
- (synopsis "Video game music file playback library")
- (description
- "Game-music-emu is a collection of video game music file emulators that
-support the following formats and systems:
-@table @code
-@item AY
-ZX Spectrum/Asmtrad CPC
-@item GBS
-Nintendo Game Boy
-@item GYM
-Sega Genesis/Mega Drive
-@item HES
-NEC TurboGrafx-16/PC Engine
-@item KSS
-MSX Home Computer/other Z80 systems (doesn't support FM sound)
-@item NSF/NSFE
-Nintendo NES/Famicom (with VRC 6, Namco 106, and FME-7 sound)
-@item SAP
-Atari systems using POKEY sound chip
-@item SPC
-Super Nintendo/Super Famicom
-@item VGM/VGZ
-Sega Master System/Mark III, Sega Genesis/Mega Drive, BBC Micro
-@end table")
- (license (list license:lgpl2.1+
- ;; demo and player directories are under the Expat license
- license:expat))))
-
(define-public lingot
(package
(name "lingot")