summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-09-04 12:01:37 +0200
committerOleg Pykhalov <go.wigust@gmail.com>2019-09-06 12:37:41 +0300
commit43931643a68363e1494a00227d3292806a9a7b4a (patch)
treea2c2f86a856bb06e32deb8e819c034ef1939d2a0
parent14c9c456c740f125a843b11303e311e4ab311f07 (diff)
downloadguix-patches-43931643a68363e1494a00227d3292806a9a7b4a.tar
guix-patches-43931643a68363e1494a00227d3292806a9a7b4a.tar.gz
gnu: Add emacs-leetcode.
* gnu/packages/emacs-xyz.scm (emacs-leetcode): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ab3365591f..0ca1af9d05 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15853,6 +15853,31 @@ buffers, etc. It also has plug-ins to help your Emacs life.")
programs can use this table component for the application UI.")
(license license:gpl3+))))
+(define-public emacs-leetcode
+ (let ((commit "8624496af9e105c3e07d88844b37ede87540d604")
+ (revision "1"))
+ (package
+ (name "emacs-leetcode")
+ (version (git-version "0" "1" commit))
+ (home-page "https://github.com/ginqi7/leetcode-emacs.git")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ginqi7/leetcode-emacs")
+ (commit commit)))
+ (sha256
+ (base32
+ "11pp7ydlmwrv7djf9mwk4xzn295xbmdnj5x13bfj5yjpjr89p531"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-names" ,emacs-names)
+ ("emacs-ctable" ,emacs-ctable)))
+ (synopsis "Solve and submit LeetCode problems from within Emacs")
+ (description "This package provides an Emacs interface to LeetCode
+allowing users to log in and solve problems of their choice using Emacs.")
+ (license license:unlicense))))
+
(define-public emacs-epc
(let ((commit "e1bfa5ca163273859336e3cc89b4b6460f7f8cda"))
(package