summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSheng Yang <yangsheng6810@gmail.com>2022-01-23 21:46:27 -0600
committerLudovic Courtès <ludo@gnu.org>2022-03-06 22:49:48 +0100
commitd3fb8036b78ccdd8b14f386b4a5c50ce42f93f78 (patch)
treec83f80ccb1c81a11a81e30d78aadc69d63742751
parentb16e17f34c8803ac8510cfbc6f5d766e1e564939 (diff)
downloadguix-patches-d3fb8036b78ccdd8b14f386b4a5c50ce42f93f78.tar
guix-patches-d3fb8036b78ccdd8b14f386b4a5c50ce42f93f78.tar.gz
gnu: Add jtdx.
* gnu/packages/radio.scm (jtdx-hamlib): New variable. (jtdx): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/radio.scm66
1 files changed, 66 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index c096a01ae8..ba994ad1ef 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2021 João Pedro Simas <jpsimas@gmail.com>
;;; Copyright © 2021 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 Sheng Yang <styang@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1114,6 +1115,30 @@ users.")
"--with-tcl-binding"
"--with-xml-support")))))
+(define-public jtdx-hamlib
+ ;; Fork of hamlib with custom patches used by jtdx.
+ (package
+ (inherit hamlib)
+ (name "jtdx-hamlib")
+ (version "2.2.158")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jtdx-project/jtdxhamlib.git")
+ (commit "158")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0m9i5k1n6j0nvmsqcy12x2ngqzjvxxlc3jg29igh93hb7lprlkjv"))))
+ (native-inputs
+ (modify-inputs (package-native-inputs hamlib)
+ (prepend autoconf automake libtool texinfo)))
+ (arguments
+ `(#:configure-flags '("--disable-shared"
+ "--enable-static"
+ "--without-cxx-binding"
+ "--disable-winradio")))))
+
(define-public tlf
(package
(name "tlf")
@@ -1207,6 +1232,47 @@ weak-signal conditions.")
(home-page "https://www.physics.princeton.edu/pulsar/k1jt/wsjtx.html")
(license license:gpl3)))
+(define-public jtdx
+ (package
+ (name "jtdx")
+ (version "2.2.158")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jtdx-project/jtdx")
+ (commit "158")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1lw9q7ggh2jlasipl3v5pkbabysjr6baw15lnmg664ah3fwdrvnx"))))
+ (build-system qt-build-system)
+ (native-inputs
+ (list asciidoc gfortran pkg-config qttools ruby-asciidoctor))
+ (inputs
+ (list
+ boost
+ fftw
+ fftwf
+ jtdx-hamlib
+ libusb
+ qtbase-5
+ qtwebsockets
+ qtmultimedia
+ qtserialport))
+ (arguments
+ `(#:tests? #f)) ; No test suite
+ (synopsis "Weak-signal ham radio communication program, forked from WSJTX")
+ (description
+ "JTDX means \"JT,T10 and FT8 and FT4 modes for DXing\", it is being
+developed with main focus on the sensitivity and decoding efficiency, both, in
+overcrowded and half empty HF band conditions.
+
+It is modified WSJT-X software forked from WSJT-X r6462. JTDX supports JT9,
+JT65, T10, FT8 and FT4 © digital modes for HF amateur radio communication,
+focused on DXing and being shaped by community of DXers.JTDX")
+ (home-page "https://www.jtdx.tech/en/")
+ (license license:gpl3)))
+
(define-public js8call
(package
(inherit wsjtx)