summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2022-03-07 16:41:33 +0100
committerLudovic Courtès <ludo@gnu.org>2022-03-07 22:49:27 +0100
commit6e09ab9f614916ad850155407755ef3421a23775 (patch)
tree4e623e35bfdb590987250d133fb393cf06bebb51
parent667f21aea000b988f2587f9039be25e61a2cbb08 (diff)
downloadguix-patches-6e09ab9f614916ad850155407755ef3421a23775.tar
guix-patches-6e09ab9f614916ad850155407755ef3421a23775.tar.gz
gnu: scotch: Explicitly pass "-DINTSIZE" to CMake.
Previously, the 'scotch' and 'pt-scotch' packages would use the default int size, which turned out to be 32 on x86_64-linux instead of 64 as it used to be in Scotch 6.x. * gnu/packages/maths.scm (scotch)[arguments]: Add "-DINTSIZE" to #:configure-flags. (scotch32)[arguments]: Likewise. (pt-scotch)[arguments]: Likewise. (pt-scotch32)[arguments]: Likewise.
-rw-r--r--gnu/packages/maths.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4c0ce93eef..7b43a8cbe8 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3889,7 +3889,7 @@ implemented in ANSI C, and MPI for communications.")
(list flex bison gfortran))
(outputs '("out" "metis"))
(arguments
- `(#:configure-flags '("-DBUILD_SHARED_LIBS=YES"
+ `(#:configure-flags '("-DBUILD_SHARED_LIBS=YES" "-DINTSIZE=64"
"-DBUILD_PTSCOTCH=OFF")
#:phases
(modify-phases %standard-phases
@@ -3930,7 +3930,7 @@ bio-chemistry.")
(substitute-keyword-arguments (package-arguments scotch)
((#:configure-flags flags ''())
''("-DBUILD_SHARED_LIBS=YES" "-DBUILD_PTSCOTCH=OFF"
- "-DCMAKE_C_FLAGS=-DINTSIZE32=1"))))
+ "-DINTSIZE=32"))))
(synopsis
"Programs and libraries for graph algorithms (32-bit integers)")))
@@ -3943,7 +3943,8 @@ bio-chemistry.")
(arguments
(substitute-keyword-arguments (package-arguments scotch)
((#:configure-flags flags ''())
- ''("-DBUILD_SHARED_LIBS=YES" "-DBUILD_PTSCOTCH=ON"))
+ ''("-DBUILD_SHARED_LIBS=YES" "-DBUILD_PTSCOTCH=ON"
+ "-DINTSIZE=64"))
((#:phases phases '%standard-phases)
`(modify-phases ,phases
(add-before 'check 'mpi-setup
@@ -3960,7 +3961,7 @@ bio-chemistry.")
(substitute-keyword-arguments (package-arguments pt-scotch)
((#:configure-flags flags ''())
''("-DBUILD_SHARED_LIBS=YES" "-DBUILD_PTSCOTCH=ON"
- "-DCMAKE_C_FLAGS=-DINTSIZE32=1"))))
+ "-DINTSIZE=32"))))
(synopsis
"Programs and libraries for graph algorithms (with MPI and 32-bit integers)")))