summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornixo <nicolo@nixo.xyz>2021-03-28 11:59:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-04-11 11:23:30 +0200
commit2d0a546508cb63e340220a363898fa9f46f03006 (patch)
tree10a28dc3f42d969586a5f824f351f39270ac04d2
parent735527d8e944099a587e40ecbcb4782309073bb2 (diff)
downloadguix-patches-2d0a546508cb63e340220a363898fa9f46f03006.tar
guix-patches-2d0a546508cb63e340220a363898fa9f46f03006.tar.gz
gnu: Add emacs-elfeed-protocol.
* gnu/packages/emacs-xyz.scm (emacs-elfeed-protocol): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a927aea227..8111aacba7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -85,7 +85,7 @@
;;; Copyright © 2020 Adam Kandur <rndd@tuta.io>
;;; Copyright © 2020 Tim Howes <timhowes@lavabit.com>
;;; Copyright © 2020 Noah Landis <noahlandis@posteo.net>
-;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2020, 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2020 André A. Gomes <andremegafone@gmail.com>
;;; Copyright © 2020 Jonathan Rostran <rostranjj@gmail.com>
;;; Copyright © 2020, 2021 Noah Evans <noah@nevans.me>
@@ -9210,6 +9210,30 @@ duplicated a lot. Org-mode makes the book keeping of tags and feeds
much easier.")
(license license:gpl3+))))
+(define-public emacs-elfeed-protocol
+ (package
+ (name "emacs-elfeed-protocol")
+ (version "0.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fasheng/elfeed-protocol")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "07r1qlldgd0kfikd0y737y5n42ab3nkw2s5jx7frimj41yandbdp"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-elfeed" ,emacs-elfeed)))
+ (home-page "https://github.com/fasheng/elfeed-protocol")
+ (synopsis "Fever/NewsBlur/ownCloud/tt-RSS protocols for Elfeed")
+ (description
+ "Elfeed-protocol provides extra protocols to make self-hosting RSS
+readers like Fever, NewsBlur, ownCloud News and Tiny TIny RSS work
+with Elfeed.")
+ (license license:gpl3+)))
+
(define-public emacs-elfeed-score
(package
(name "emacs-elfeed-score")