summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-02-22 16:00:50 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-03-06 12:24:54 +0200
commitfe8c2d907aa05fb080573becf05d342485390df1 (patch)
tree3c70b00d8bf3c85bd857a68286e616af6e3fc237
parent092dba879a2d960309a2220eeb4d792d72f8c585 (diff)
downloadguix-patches-fe8c2d907aa05fb080573becf05d342485390df1.tar
guix-patches-fe8c2d907aa05fb080573becf05d342485390df1.tar.gz
gnu: Add go-github-com-xdg-go-pbkdf2.
* gnu/packages/golang.scm (go-github-com-xdg-go-pbkdf2): New variable.
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 500b8d96d6..46ca2d574c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7943,6 +7943,29 @@ including errata. It also provides a profile for SASLprep as defined in
RFC-4013.")
(license license:asl2.0)))
+(define-public go-github-com-xdg-go-pbkdf2
+ (package
+ (name "go-github-com-xdg-go-pbkdf2")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xdg-go/pbkdf2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1nipijy5xkdnfyhkp5ryrjzm14si1i2v2xyfmblf84binwkbr8jh"))))
+ (build-system go-build-system)
+ (arguments '(#:import-path "github.com/xdg-go/pbkdf2"))
+ (home-page "https://github.com/xdg-go/pbkdf2")
+ (synopsis "Go implementation of PBKDF2")
+ (description
+ "Package pbkdf2 implements password-based key derivation using the PBKDF2
+algorithm described in @url{https://rfc-editor.org/rfc/rfc2898.html,RFC 2898}
+and @url{https://rfc-editor.org/rfc/rfc8018.html,RFC 8018}.")
+ (license license:asl2.0)))
+
(define-public go-github-com-godbus-dbus
(package
(name "go-github-com-godbus-dbus")