summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-06 22:44:51 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-06 22:44:51 +0100
commitf75becbb36605da75a6b0d235f565943279fdbae (patch)
treebdda2ed9edc72b31411a04b1454f4364baf7e198
parent48e72ee82be6587721fe8ba16a4e31b32da9a1d0 (diff)
downloadguix-patches-f75becbb36605da75a6b0d235f565943279fdbae.tar
guix-patches-f75becbb36605da75a6b0d235f565943279fdbae.tar.gz
gnu: emacs-go-mode: Activate tests.
* gnu/packages/emacs-xyz.scm (emacs-go-mode)[arguments]: Activate tests.
-rw-r--r--gnu/packages/emacs-xyz.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bd222d9cc9..a7a711edb4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3253,7 +3253,23 @@ current match, total matches and exit status.
(sha256
(base32
"00qzn136d8cl3szbi44xf3iiv75r6n1m7wwgldmzn4i5mpz8dbq7"))))
+ (arguments
+ (list
+ #:tests? #t
+ #:test-command #~(list "ert-runner")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'fix-tests
+ ;; Two tests fail because they (wrongly) assume we run them from
+ ;; the "test" sub-directory. Fix their expectations.
+ (lambda _
+ (let ((test-file "test/go-indentation-test.el"))
+ (make-file-writable test-file)
+ (substitute* test-file
+ (("testdata/indentation_tests/" all)
+ (string-append "test/" all)))))))))
(build-system emacs-build-system)
+ (native-inputs (list emacs-ert-runner))
(home-page "https://github.com/dominikh/go-mode.el")
(synopsis "Go mode for Emacs")
(description