summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-02-22 16:00:21 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-03-06 12:24:51 +0200
commit092dba879a2d960309a2220eeb4d792d72f8c585 (patch)
tree48129a37fbbe2b16c7cc2b84223c3f6616678797
parent18b0527765301a3015afb9ba1209bd10f56426cb (diff)
downloadguix-patches-092dba879a2d960309a2220eeb4d792d72f8c585.tar
guix-patches-092dba879a2d960309a2220eeb4d792d72f8c585.tar.gz
gnu: Add go-github-com-docker-go-units.
* gnu/packages/golang.scm (go-github-com-docker-go-units): New variable.
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b59550e0ad..500b8d96d6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3892,6 +3892,28 @@ the Go language. In particular it provides tools to deal with network address
translation (NAT), proxies, sockets, and transport layer security (TLS).")
(license license:asl2.0))))
+(define-public go-github-com-docker-go-units
+ (package
+ (name "go-github-com-docker-go-units")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/docker/go-units")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0k8gja8ql4pqg5rzmqvka42vjfs6rzablak87whcnqba6qxpimvz"))))
+ (build-system go-build-system)
+ (arguments '(#:import-path "github.com/docker/go-units"))
+ (home-page "https://github.com/docker/go-units")
+ (synopsis "Parse and print size and time units in human-readable format")
+ (description
+ "@code{go-units} is a library to transform human friendly measurements into
+machine friendly values.")
+ (license license:asl2.0)))
+
(define-public go-github-com-docker-machine
(let ((commit "7b7a141da84480342357c51838be142bf183b095")
(revision "0"))