summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-07-29 13:53:35 +0200
committerMarius Bakke <marius@gnu.org>2021-07-29 14:10:13 +0200
commitbc55f3091bac4677df0cf020381c554921fea179 (patch)
tree54dfff27f7fd83675771ba4551cad1d487842984
parentcdd3141f195f7e9527988f35cc1066475a7ac40d (diff)
downloadguix-patches-bc55f3091bac4677df0cf020381c554921fea179.tar
guix-patches-bc55f3091bac4677df0cf020381c554921fea179.tar.gz
gnu: util-linux: Explicitly depend on 'file'.
...instead of using the variant that happens to be in %FINAL-INPUTS. * gnu/packages/linux.scm (util-linux)[inputs]: Add FILE. While at it, remove labels. [native-inputs]: Remove labels.
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d5ee18081e..e17bc37ed2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1836,11 +1836,13 @@ providing the system administrator with some help in common tasks.")
(substitute* (find-files (string-append lib "/lib/pkgconfig")
"\\.pc$")
(("^(exec_)?prefix=.*") ""))))))))
- (inputs `(("zlib" ,zlib)
- ("ncurses" ,ncurses)))
+ (inputs
+ (list file ;for libmagic
+ ncurses
+ zlib))
(native-inputs
- `(("perl" ,perl)
- ("net-base" ,net-base))) ;for tests
+ (list net-base ;for tests
+ perl))
(home-page "https://www.kernel.org/pub/linux/utils/util-linux/")
(synopsis "Collection of utilities for the Linux kernel")
(description "Util-linux is a diverse collection of Linux kernel