summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2022-02-21 19:33:03 +0100
committerLudovic Courtès <ludo@gnu.org>2022-03-03 23:57:01 +0100
commitbb41642077b67cd975d073e7904a90c67569ff56 (patch)
treecc8545936bd4cef403f7d6542ecc3a09e7f7f25f
parentf1c18e17663353d4a46f6dc23da72f49c53549cb (diff)
downloadguix-patches-bb41642077b67cd975d073e7904a90c67569ff56.tar
guix-patches-bb41642077b67cd975d073e7904a90c67569ff56.tar.gz
gnu: Add wtype.
* gnu/packages/freedesktop.scm (wtype): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/freedesktop.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 6215a46cb4..55bde8e705 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1210,6 +1210,29 @@ sent to a Wayland window, such as key presses. It is analogous to the X11 tool
XEv.")
(license license:expat)))
+(define-public wtype
+ (package
+ (name "wtype")
+ (version "0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/atx/wtype.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0bpix92vzip9vlhzihj3k8h9flrlna231x3y8ah7p4965l177yjd"))))
+ (build-system meson-build-system)
+ (native-inputs
+ (list pkg-config wayland libxkbcommon))
+ (synopsis "Xdotool type for Wayland")
+ (description "Wtype lets you simulate keyboard input and mouse activity,
+move and resize windows, etc.")
+ (home-page "https://github.com/atx/wtype")
+ ;; MIT License
+ (license license:expat)))
+
(define-public exempi
(package
(name "exempi")