summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-02-27 16:29:20 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-03-04 23:44:54 +0100
commit992ed3b4ce20335ca61df0d29bfd02495dee87e6 (patch)
tree67f87a24a13fe4c902d6734e411b959cc9d1e4a6
parent9e9e4686f76c17e4bc926377637d66626a63b9a0 (diff)
downloadguix-patches-992ed3b4ce20335ca61df0d29bfd02495dee87e6.tar
guix-patches-992ed3b4ce20335ca61df0d29bfd02495dee87e6.tar.gz
gnu: racket-vm-cs: Build with "--enable-scheme".
* gnu/packages/racket.scm (racket-vm-cs)[native-inputs]: Replace 'chez-scheme-for-racket-bootstrap-bootfiles' with 'chez-scheme-for-racket'. [arguments]<#:phases>: Delete 'unpack-bootfiles'. <#:configure-flags>: Add "--enable-scheme". Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/racket.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/racket.scm b/gnu/packages/racket.scm
index d754e853a9..471a11dd48 100644
--- a/gnu/packages/racket.scm
+++ b/gnu/packages/racket.scm
@@ -369,7 +369,7 @@ collector, 3M (``Moving Memory Manager'').")
(native-inputs
(modify-inputs (package-native-inputs racket-vm-cgc)
(delete "libtool")
- (prepend chez-scheme-for-racket-bootstrap-bootfiles
+ (prepend chez-scheme-for-racket
chez-nanopass-bootstrap
racket-vm-bc)))
(arguments
@@ -379,18 +379,15 @@ collector, 3M (``Moving Memory Manager'').")
(add-after 'unpack 'unpack-nanopass+stex
(lambda args
(with-directory-excursion "racket/src/ChezScheme"
- #$unpack-nanopass+stex)))
- (add-after 'unpack-nanopass+stex 'unpack-bootfiles
- (lambda* (#:key native-inputs inputs #:allow-other-keys)
- (with-directory-excursion "racket/src/ChezScheme"
- (copy-recursively
- (search-input-directory (or native-inputs inputs)
- "lib/chez-scheme-bootfiles")
- "boot"))))))
+ #$unpack-nanopass+stex)))))
((#:configure-flags _ '())
#~(cons* "--enable-csonly"
"--enable-libz"
"--enable-lz4"
+ (string-append "--enable-scheme="
+ #$(this-package-native-input
+ "chez-scheme-for-racket")
+ "/bin/scheme")
#$(racket-vm-common-configure-flags)))))
(synopsis "Racket CS implementation")
(description "The Racket CS implementation, which uses ``Chez Scheme'' as