summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2022-02-24 22:09:45 +0000
committerPierre Langlois <pierre.langlois@gmx.com>2022-03-03 23:03:04 +0000
commit74130e73c019d7f2bc0700eca04d797d2645ffa4 (patch)
tree17df765db987143df8aceb93146ec7c9b99d97c8
parentd93bb18386cbd936c2cf35d013c60f33c5a25010 (diff)
downloadguix-patches-74130e73c019d7f2bc0700eca04d797d2645ffa4.tar
guix-patches-74130e73c019d7f2bc0700eca04d797d2645ffa4.tar.gz
gnu: dovecot: Fix backtrace test on aarch64.
* gnu/packages/mail.scm (dovecot)[arguments]: Add LDFLAGS=-rdynamic to make-flags.
-rw-r--r--gnu/packages/mail.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index fb24546af6..b0b9ae9f76 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1895,6 +1895,10 @@ facilities for checking incoming mail.")
"--localstatedir=/var"
"--with-sqlite" ; not auto-detected
"--with-lucene") ; not auto-detected
+ ;; The -rdynamic linker flag is needed for the backtrace() function to
+ ;; have symbol names rather than just addresses. Dovecot's tests rely
+ ;; on this, see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=962630.
+ #:make-flags (list "LDFLAGS=-rdynamic")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-file-names