summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2022-02-02 09:45:11 -0300
committerVinicius Monego <monego@posteo.net>2022-03-04 19:18:12 -0300
commit5b248cc23ee0c2b34b9ad88c9ba86664d6a3eebf (patch)
treeb8b461e3e8a44f4f22ad10bd5d358a6bf83a07e7
parentd049ff159980954dccb6bc578b1df1efbc408e92 (diff)
downloadguix-patches-5b248cc23ee0c2b34b9ad88c9ba86664d6a3eebf.tar
guix-patches-5b248cc23ee0c2b34b9ad88c9ba86664d6a3eebf.tar.gz
gnu: kdenlive: Update to 21.12.3.
* gnu/packages/kde.scm (kdenlive): Update to 21.12.3. [source]: Use git-file-name function. [inputs]: Add bash-minimal.
-rw-r--r--gnu/packages/kde.scm149
1 files changed, 75 insertions, 74 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index c9351ccad9..4946cf1b3a 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2020, 2021, 2022 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2021 la snesne <lasnesne@lagunposprasihopre.org>
-;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021, 2022 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -45,6 +45,7 @@
#:use-module (gnu packages apr)
#:use-module (gnu packages astronomy)
#:use-module (gnu packages audio)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
@@ -219,84 +220,84 @@ browser for easy news reading.")
(license license:gpl2+)))
(define-public kdenlive
- (let ((version "21.08.3"))
- (package
- (name "kdenlive")
- (version version)
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://invent.kde.org/multimedia/kdenlive")
- (commit (string-append "v" version))))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32 "0lpspak5djkbn2xbmmbxls258310g45n3a08sghkjl08bx6ilvc9"))))
- (build-system qt-build-system)
- (native-inputs
- (list extra-cmake-modules pkg-config qttools))
- (inputs
- (list breeze ; make dark them available easily
- breeze-icons ; recommended icon set
- ffmpeg
- frei0r-plugins
- karchive
- kcrash
- kdbusaddons
- kdeclarative
- kdoctools
- kfilemetadata
- kguiaddons
- kiconthemes
- knewstuff
- knotifications
- knotifyconfig
- kparts
- kplotting
- mlt
- purpose
- qtbase-5
- qtdeclarative
- qtgraphicaleffects
- qtmultimedia
- qtnetworkauth
- qtquickcontrols
- qtquickcontrols2
- qtscript
- qtsvg
- shared-mime-info))
- (arguments
- ;; XXX: there is a single test that spawns other tests and
- ;; 1/3 tests failed and 1/327 assertions failed. It seems
- ;; that individual tests can't be skipped.
- `(#:configure-flags (list "-DBUILD_TESTING=off")
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'wrap-executable
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (qtbase (assoc-ref inputs "qtbase"))
- (frei0r (assoc-ref inputs "frei0r-plugins"))
- (ffmpeg (assoc-ref inputs "ffmpeg")))
- (wrap-program (string-append out "/bin/kdenlive")
- `("PATH" ":" prefix
- ,(list (string-append ffmpeg "/bin")))
- `("FREI0R_PATH" ":" =
- (,(string-append frei0r "/lib/frei0r-1/")))
- `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
- (,(string-append qtbase "/lib/qt5/plugins/platforms")))
- `("MLT_PREFIX" ":" =
- (,(assoc-ref inputs "mlt"))))))))))
- (home-page "https://kdenlive.org")
- (synopsis "Non-linear video editor")
- (description "Kdenlive is an acronym for KDE Non-Linear Video Editor.
+ (package
+ (name "kdenlive")
+ (version "21.12.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://invent.kde.org/multimedia/kdenlive")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19fs5zhz1nv5cvf709c5741nri139pl5mzpf2xnd4sqj0rmyv228"))))
+ (build-system qt-build-system)
+ (arguments
+ ;; XXX: there is a single test that spawns other tests and
+ ;; 1/3 tests failed and 1/327 assertions failed. It seems
+ ;; that individual tests can't be skipped.
+ `(#:configure-flags (list "-DBUILD_TESTING=off")
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (qtbase (assoc-ref inputs "qtbase"))
+ (frei0r (assoc-ref inputs "frei0r-plugins"))
+ (ffmpeg (assoc-ref inputs "ffmpeg")))
+ (wrap-program (string-append out "/bin/kdenlive")
+ `("PATH" ":" prefix
+ ,(list (string-append ffmpeg "/bin")))
+ `("FREI0R_PATH" ":" =
+ (,(string-append frei0r "/lib/frei0r-1/")))
+ `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
+ (,(string-append qtbase "/lib/qt5/plugins/platforms")))
+ `("MLT_PREFIX" ":" =
+ (,(assoc-ref inputs "mlt"))))))))))
+ (native-inputs
+ (list extra-cmake-modules pkg-config qttools))
+ (inputs
+ (list bash-minimal
+ breeze ; make dark them available easily
+ breeze-icons ; recommended icon set
+ ffmpeg
+ frei0r-plugins
+ karchive
+ kcrash
+ kdbusaddons
+ kdeclarative
+ kdoctools
+ kfilemetadata
+ kguiaddons
+ kiconthemes
+ knewstuff
+ knotifications
+ knotifyconfig
+ kparts
+ kplotting
+ mlt
+ purpose
+ qtbase-5
+ qtdeclarative
+ qtgraphicaleffects
+ qtmultimedia
+ qtnetworkauth
+ qtquickcontrols
+ qtquickcontrols2
+ qtscript
+ qtsvg
+ shared-mime-info))
+ (home-page "https://kdenlive.org")
+ (synopsis "Non-linear video editor")
+ (description "Kdenlive is an acronym for KDE Non-Linear Video Editor.
Non-linear video editing is much more powerful than beginner's (linear)
editors, hence it requires a bit more organization before starting. However,
it is not reserved to specialists and can be used for small personal
projects.")
- (license license:gpl2+))))
+ (license license:gpl2+)))
(define-public kdevelop
(package