summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2022-03-04 18:15:36 -0300
committerVinicius Monego <monego@posteo.net>2022-03-04 19:18:20 -0300
commit4e1f20b43e5345a4ce5d2e8b37b5b24280b4b277 (patch)
tree80d5ab7539edd24e6cf97b545da37c4b1ff6b62c
parent5b248cc23ee0c2b34b9ad88c9ba86664d6a3eebf (diff)
downloadguix-patches-4e1f20b43e5345a4ce5d2e8b37b5b24280b4b277.tar
guix-patches-4e1f20b43e5345a4ce5d2e8b37b5b24280b4b277.tar.gz
gnu: kdenlive: Add dependency on ladspa.
* gnu/packages/kde.scm (kdenlive)[inputs]: Add ladspa. [arguments]<#:phases>: Wrap LADSPA_PATH in the 'wrap-executable phase.
-rw-r--r--gnu/packages/kde.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 4946cf1b3a..9328722e94 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -244,14 +244,17 @@ browser for easy news reading.")
(add-after 'install 'wrap-executable
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (qtbase (assoc-ref inputs "qtbase"))
+ (ffmpeg (assoc-ref inputs "ffmpeg"))
(frei0r (assoc-ref inputs "frei0r-plugins"))
- (ffmpeg (assoc-ref inputs "ffmpeg")))
+ (ladspa (assoc-ref inputs "ladspa"))
+ (qtbase (assoc-ref inputs "qtbase")))
(wrap-program (string-append out "/bin/kdenlive")
`("PATH" ":" prefix
,(list (string-append ffmpeg "/bin")))
`("FREI0R_PATH" ":" =
- (,(string-append frei0r "/lib/frei0r-1/")))
+ (,(string-append frei0r "/lib/frei0r-1")))
+ `("LADSPA_PATH" ":" =
+ (,(string-append ladspa "/lib/ladspa")))
`("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
(,(string-append qtbase "/lib/qt5/plugins/platforms")))
`("MLT_PREFIX" ":" =
@@ -277,6 +280,7 @@ browser for easy news reading.")
knotifyconfig
kparts
kplotting
+ ladspa
mlt
purpose
qtbase-5