summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-02-06 21:27:53 -0500
committerLudovic Courtès <ludo@gnu.org>2022-03-03 23:57:01 +0100
commit17c3bc1955561411534fd3ce3a00b490ad166cc2 (patch)
treed1a4eb75b0c579fe11b070786d927e6e278c5c56
parent48bd8b408e1de93e8dc8bf134942b7b6141fc6ad (diff)
downloadguix-patches-17c3bc1955561411534fd3ce3a00b490ad166cc2.tar
guix-patches-17c3bc1955561411534fd3ce3a00b490ad166cc2.tar.gz
gnu: Add jj.
* gnu/packages/messaging.scm (jj): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/messaging.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 3402a63acc..1d0c36cf23 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3133,6 +3133,41 @@ API. Mattermost is not required.")
(home-page "https://github.com/42wim/matterbridge")
(license license:asl2.0)))
+(define-public jj
+ (package
+ (name "jj")
+ (version "2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://23.fi/jj/jj-" version ".tar.gz"))
+ (sha256
+ (base32
+ "02xz2ci93bccvil5iff804mh3zr5iqkf6zx5mxgraz17xg0azlgh"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ;There are no tests.
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "jj" bin)))))))
+ (native-inputs (list pkg-config))
+ (inputs (list glib loudmouth))
+ (home-page "https://23.fi/jj/")
+ (synopsis "FIFO based Jabber client")
+ (description
+ "jj is a simple file-system-based Jabber client, inspired by ii IRC
+client. Interaction with jj is done by writing and reading files from the
+server directory which jj creates. It is perfect for bots and
+notifications.")
+ (license license:expat)))
+
(define-public pounce
(package
(name "pounce")