summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-03 16:05:17 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-03 16:05:17 +0100
commit734b76c5fc096fb5e0ad78e4c4e31b16272ed70b (patch)
treed5a0ec96d7887f3a66c4ea94c28667d278ec775b
parent9e154465b2265359a8ec7bb27defc4449a3a15ff (diff)
downloadguix-patches-734b76c5fc096fb5e0ad78e4c4e31b16272ed70b.tar
guix-patches-734b76c5fc096fb5e0ad78e4c4e31b16272ed70b.tar.gz
gnu: texlive-wrapfig: Install missing documentation files.
* gnu/packages/tex.scm (texlive-wrapfig): Install missing documentation files.
-rw-r--r--gnu/packages/tex.scm32
1 files changed, 7 insertions, 25 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c430e9968c..77f306f79c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7110,31 +7110,13 @@ implements an easy to use interface for these symbols.")
(define-public texlive-wrapfig
(package
- (name "texlive-wrapfig")
- (version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/latex/wrapfig"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "16xpyl0csmmwndz1xhzqfg9l0zcsnqxslsixsqkwd4zsvfj30sv4"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/tex/latex/wrapfig")))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs "source") target)
- #t))))
- (home-page "https://www.ctan.org/pkg/wrapfig")
+ (inherit
+ (simple-texlive-package
+ "texlive-wrapfig"
+ (list "doc/latex/wrapfig/" "tex/latex/wrapfig/")
+ (base32 "0wk1vp0dqsp597xzsqbwj8xk80v7d77qmpjir84n54f920rf9ka9")
+ #:trivial? #t))
+ (home-page "https://ctan.org/macros/latex/contrib/wrapfig")
(synopsis "Produces figures which text can flow around")
(description
"This package allows figures or tables to have text wrapped around them.