summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-02-27 01:00:01 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-02-27 01:00:00 +0100
commit3a72ee1046e96e5c5c03e4db4721f0e29c8c9db6 (patch)
tree6f470d9e19ffb6c6896efc0a40b7caa8d1808297
parent7620dacc8b4d364da3e3b3875d5be9323f75552a (diff)
downloadguix-patches-3a72ee1046e96e5c5c03e4db4721f0e29c8c9db6.tar
guix-patches-3a72ee1046e96e5c5c03e4db4721f0e29c8c9db6.tar.gz
gnu: flightgear: Use G-expressions.
This fixes the build by removing broken usage of %outputs. * gnu/packages/games.scm (flightgear)[arguments]: Rewrite as G-expressions.
-rw-r--r--gnu/packages/games.scm66
1 files changed, 33 insertions, 33 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a39470a07b..a47bc909a7 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9178,39 +9178,39 @@ and also provides the base for the FlightGear Flight Simulator.")
#t))))
(build-system qt-build-system)
(arguments
- `(#:configure-flags
- (list "-DSYSTEM_SQLITE=ON"
- "-DSYSTEM_CPPUNIT=ON"
- (string-append "-DFG_DATA_DIR="
- (assoc-ref %outputs "out")
- "/share/flightgear"))
- ;; TODO: test suite segfaults.
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'skip-some-tests
- (lambda _
- (substitute* "test_suite/unit_tests/Instrumentation/test_gps.hxx"
- (("CPPUNIT_TEST\\(testLongLegWestbound\\);" all)
- (string-append "// " all))
- (("CPPUNIT_TEST\\(testFinalLegCourse\\);" all)
- (string-append "// " all)))))
- (add-after 'build 'build-test-suite
- (lambda* args
- ((assoc-ref %standard-phases 'build)
- #:make-flags (list "fgfs_test_suite"))))
- ;; Test suite needs access to FGData so run it after 'install.
- (delete 'check)
- (add-after 'install-data 'check
- (assoc-ref %standard-phases 'check))
- (add-after 'install 'install-data
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((share (string-append (assoc-ref outputs "out") "/share/flightgear")))
- (mkdir-p share)
- (with-directory-excursion share
- (invoke "tar" "xf" (assoc-ref inputs "flightgear-data")
- "--strip-components=1")))
- #t)))))
+ (list #:configure-flags
+ #~(list "-DSYSTEM_SQLITE=ON"
+ "-DSYSTEM_CPPUNIT=ON"
+ (string-append "-DFG_DATA_DIR=" #$output "/share/flightgear"))
+ ;; TODO: test suite segfaults.
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-some-tests
+ (lambda _
+ (substitute*
+ "test_suite/unit_tests/Instrumentation/test_gps.hxx"
+ (("CPPUNIT_TEST\\(testLongLegWestbound\\);" all)
+ (string-append "// " all))
+ (("CPPUNIT_TEST\\(testFinalLegCourse\\);" all)
+ (string-append "// " all)))))
+ (add-after 'build 'build-test-suite
+ (lambda* args
+ ((assoc-ref %standard-phases 'build)
+ #:make-flags (list "fgfs_test_suite"))))
+ ;; Test suite needs access to FGData so run it after 'install.
+ (delete 'check)
+ (add-after 'install-data 'check
+ (assoc-ref %standard-phases 'check))
+ (add-after 'install 'install-data
+ (lambda _
+ (let ((share (string-append #$output "/share/flightgear")))
+ (mkdir-p share)
+ (with-directory-excursion share
+ (invoke "tar" "xf"
+ #$(this-package-native-input "flightgear-data")
+ "--strip-components=1")))
+ #t)))))
(inputs
(list boost
dbus