summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-03-02 18:55:54 +0100
committerLudovic Courtès <ludo@gnu.org>2022-03-02 19:26:16 +0100
commit96bc9420cb83b8a600cff3a2f3ec390802f648c6 (patch)
tree56135d21ade19d3e70dc3157ae960cfd99541ff0
parentf0efa6afc5f180f778eb320631a71f42bf1b211f (diff)
downloadguix-patches-96bc9420cb83b8a600cff3a2f3ec390802f648c6.tar
guix-patches-96bc9420cb83b8a600cff3a2f3ec390802f648c6.tar.gz
gnu: hypre: Remove input labels.
* gnu/packages/maths.scm (hypre)[native-inputs, inputs]: Remove labels. (hypre-openmpi)[inputs]: Use 'modify-inputs'.
-rw-r--r--gnu/packages/maths.scm99
1 files changed, 49 insertions, 50 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 16050f8840..4c0ce93eef 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5371,53 +5371,52 @@ set.")
(outputs '("out" ;5.3 MiB of headers and libraries
"doc")) ;12 MiB of documentation
(native-inputs
- `(("doc++" ,doc++)
- ("doxygen" ,doxygen)
- ("python" ,python)
- ("python-breathe" ,python-breathe)
- ("python-sphinx" ,python-sphinx)
- ("texlive" ,(texlive-updmap.cfg (list texlive-adjustbox
- texlive-amsfonts
- texlive-bibtex
- texlive-capt-of
- texlive-caption
- texlive-cm
- texlive-etoolbox
- texlive-jknappen
- texlive-sectsty
- texlive-tex-gyre
- texlive-wasy
- texlive-xcolor
- texlive-xypic
- texlive-generic-listofitems
- texlive-latex-cmap
- texlive-latex-colortbl
- texlive-latex-etoc
- texlive-latex-fancyhdr
- texlive-latex-fancyvrb
- texlive-latex-float
- texlive-latex-fncychap
- texlive-latex-framed
- texlive-latex-geometry
- texlive-latex-hanging
- texlive-hyperref
- texlive-latex-multirow
- texlive-latex-natbib
- texlive-latex-needspace
- texlive-latex-newunicodechar
- texlive-latex-parskip
- texlive-latex-stackengine
- texlive-latex-tabulary
- texlive-latex-titlesec
- texlive-latex-tocloft
- texlive-latex-upquote
- texlive-latex-varwidth
- texlive-ulem
- texlive-wasysym
- texlive-wrapfig)))))
+ (list doc++
+ doxygen
+ python
+ python-breathe
+ python-sphinx
+ (texlive-updmap.cfg (list texlive-adjustbox
+ texlive-amsfonts
+ texlive-bibtex
+ texlive-capt-of
+ texlive-caption
+ texlive-cm
+ texlive-etoolbox
+ texlive-jknappen
+ texlive-sectsty
+ texlive-tex-gyre
+ texlive-wasy
+ texlive-xcolor
+ texlive-xypic
+ texlive-generic-listofitems
+ texlive-latex-cmap
+ texlive-latex-colortbl
+ texlive-latex-etoc
+ texlive-latex-fancyhdr
+ texlive-latex-fancyvrb
+ texlive-latex-float
+ texlive-latex-fncychap
+ texlive-latex-framed
+ texlive-latex-geometry
+ texlive-latex-hanging
+ texlive-hyperref
+ texlive-latex-multirow
+ texlive-latex-natbib
+ texlive-latex-needspace
+ texlive-latex-newunicodechar
+ texlive-latex-parskip
+ texlive-latex-stackengine
+ texlive-latex-tabulary
+ texlive-latex-titlesec
+ texlive-latex-tocloft
+ texlive-latex-upquote
+ texlive-latex-varwidth
+ texlive-ulem
+ texlive-wasysym
+ texlive-wrapfig))))
(inputs
- `(("blas" ,openblas)
- ("lapack" ,lapack)))
+ (list openblas lapack))
(arguments
`(#:modules ((srfi srfi-1)
,@%gnu-build-system-modules)
@@ -5478,11 +5477,11 @@ problems.")
(license license:lgpl2.1)))
(define-public hypre-openmpi
- (package (inherit hypre)
+ (package
+ (inherit hypre)
(name "hypre-openmpi")
- (inputs
- `(("mpi" ,openmpi)
- ,@(package-inputs hypre)))
+ (inputs (modify-inputs (package-inputs hypre)
+ (prepend openmpi)))
(arguments
(substitute-keyword-arguments (package-arguments hypre)
((#:configure-flags flags)