summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-02 15:09:08 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-02 15:09:08 +0100
commit8e2eecc67bec5dcdc9a11dbc02c3e0852f940191 (patch)
treeb3cde73911842c7e7d6ad56a28158e2f4e199462
parent8e00050de0e3d9958685a8b0a595443b5565996b (diff)
downloadguix-patches-8e2eecc67bec5dcdc9a11dbc02c3e0852f940191.tar
guix-patches-8e2eecc67bec5dcdc9a11dbc02c3e0852f940191.tar.gz
gnu: emacs-m-buffer-el: Honor the #:tests? flag.
* gnu/packages/emacs-xyz.scm (emacs-m-buffer-el)[arguments]: Adjust custom 'check phase to honor the #:tests? flag.
-rw-r--r--gnu/packages/emacs-xyz.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 045f5d21ae..52dff21e4d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18882,11 +18882,12 @@ mode.")
`(#:phases
(modify-phases %standard-phases
(add-before 'install 'check
- (lambda* (#:key inputs #:allow-other-keys)
- (invoke "emacs" "--batch" "-L" "."
- "-l" "test/m-buffer-test.el"
- "-l" "test/m-buffer-at-test.el"
- "-f" "ert-run-tests-batch-and-exit"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "emacs" "--batch" "-L" "."
+ "-l" "test/m-buffer-test.el"
+ "-l" "test/m-buffer-at-test.el"
+ "-f" "ert-run-tests-batch-and-exit")))))))
(build-system emacs-build-system)
(home-page "https://github.com/phillord/m-buffer-el")
(synopsis "List oriented buffer operations for Emacs")