summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-02 15:17:58 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-02 15:17:58 +0100
commit4ce63e1fbda6f9fb6fac2b1d706dc2f012683b3d (patch)
tree014354d2f46f2eb8659f1993142b603eb3e12a7f
parent9aa53a004fdc0ef7bca4de67d9d0807ed8936cb4 (diff)
downloadguix-patches-4ce63e1fbda6f9fb6fac2b1d706dc2f012683b3d.tar
guix-patches-4ce63e1fbda6f9fb6fac2b1d706dc2f012683b3d.tar.gz
gnu: emacs-macrostep: Use G-expressions.
* gnu/packages/emacs-xyz.scm (emacs-macrostep)[arguments]: Use G-expressions.
-rw-r--r--gnu/packages/emacs-xyz.scm43
1 files changed, 22 insertions, 21 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1f5952fdf4..fdf982f7a5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19099,27 +19099,28 @@ without disturbing alignment.")
"1fm40mxdn289cyzgw992223dgrjmwxn4q8svyyxfaxjrpb38jhjz"))))
(build-system emacs-build-system)
(arguments
- '(#:tests? #t
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'remove-test
- ;; Fails because of requirement ‘/bin/sh’.
- (lambda _
- (let ((file "macrostep-test.el"))
- (chmod file #o644)
- (emacs-batch-edit-file file
- `(progn (progn (goto-char (point-min))
- (re-search-forward
- "(ert-deftest macrostep-expand-c-macros")
- (beginning-of-line)
- (kill-sexp))
- (basic-save-buffer))))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "emacs" "--batch" "-L" "."
- "-l" "macrostep-test.el"
- "-f" "ert-run-tests-batch-and-exit")))))))
+ (list
+ #:tests? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'remove-test
+ ;; Fails because of requirement ‘/bin/sh’.
+ (lambda _
+ (let ((file "macrostep-test.el"))
+ (make-file-writable file)
+ (emacs-batch-edit-file file
+ `(progn (progn (goto-char (point-min))
+ (re-search-forward
+ "(ert-deftest macrostep-expand-c-macros")
+ (beginning-of-line)
+ (kill-sexp))
+ (basic-save-buffer))))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "emacs" "--batch" "-L" "."
+ "-l" "macrostep-test.el"
+ "-f" "ert-run-tests-batch-and-exit")))))))
(home-page "https://github.com/joddie/macrostep")
(synopsis "Interactive macro-expander for Emacs")
(description "@code{macrostep} is an Emacs minor mode for interactively