summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-02 15:10:13 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-02 15:10:13 +0100
commit3aaec337706338ddc64852b2537ddadc9faa0a69 (patch)
tree1c55df71b89c3765f495f15b97accba7ef1775d3
parent8e2eecc67bec5dcdc9a11dbc02c3e0852f940191 (diff)
downloadguix-patches-3aaec337706338ddc64852b2537ddadc9faa0a69.tar
guix-patches-3aaec337706338ddc64852b2537ddadc9faa0a69.tar.gz
gnu: emacs-m-buffer-el: Use G-expressions.
* gnu/packages/emacs-xyz.scm (emacs-m-buffer-el)[arguments]<#:phases>: Use G-expressions.
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 52dff21e4d..a6699f2abf 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18872,22 +18872,23 @@ mode.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/phillord/m-buffer-el")
- (commit (string-append "v" version))))
+ (url "https://github.com/phillord/m-buffer-el")
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
"1sx76i59razwccvn6x7rx5a124bfyjw9fcbxf4gj7nsg33qiq809"))))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'install 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "emacs" "--batch" "-L" "."
- "-l" "test/m-buffer-test.el"
- "-l" "test/m-buffer-at-test.el"
- "-f" "ert-run-tests-batch-and-exit")))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "emacs" "--batch" "-L" "."
+ "-l" "test/m-buffer-test.el"
+ "-l" "test/m-buffer-at-test.el"
+ "-f" "ert-run-tests-batch-and-exit")))))))
(build-system emacs-build-system)
(home-page "https://github.com/phillord/m-buffer-el")
(synopsis "List oriented buffer operations for Emacs")