summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDomagoj Stolfa <domagoj.stolfa@gmail.com>2021-07-11 15:55:43 +0100
committerEfraim Flashner <efraim@flashner.co.il>2021-07-13 15:14:15 +0300
commit7dcf9131bd948a6751ab4bedb3b9aa9eab29487b (patch)
treeca55d270350f363e196b127cfabd266ac3be9093
parent7ff1f3dbf03d002dd673eb0d34ebfe806a3eef0d (diff)
downloadguix-patches-7dcf9131bd948a6751ab4bedb3b9aa9eab29487b.tar
guix-patches-7dcf9131bd948a6751ab4bedb3b9aa9eab29487b.tar.gz
gnu: Add rust-crypto-mac-0.11.
* gnu/packages/crates-io.scm (rust-crypto-mac-0.11): New variable. (rust-crypto-mac-0.10): Inherit from rust-crypto-mac-0.11. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm41
1 files changed, 31 insertions, 10 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3aee743ecf..4c18e58671 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -10879,10 +10879,10 @@ number ``crunching``.")
common cryptographic algorithms.")
(license (list license:expat license:asl2.0))))
-(define-public rust-crypto-mac-0.10
+(define-public rust-crypto-mac-0.11
(package
(name "rust-crypto-mac")
- (version "0.10.0")
+ (version "0.11.0")
(source
(origin
(method url-fetch)
@@ -10890,21 +10890,42 @@ common cryptographic algorithms.")
(file-name
(string-append name "-" version ".tar.gz"))
(sha256
- (base32 "19iyh7h9qaqrv29dhbd31rm6pq023ry78nw7jwr3qjy3l22zsms8"))))
+ (base32
+ "0ghh3qmjf7hv580zqdk4yrbg99v57jx773zb7lzi7j4hj24bdyi5"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
- #:cargo-inputs
- (("rust-blobby" ,rust-blobby-0.3)
- ("rust-cipher" ,rust-cipher-0.2)
- ("rust-generic-array" ,rust-generic-array-0.14)
- ("rust-subtle" ,rust-subtle-2))))
+ `(#:cargo-inputs
+ (("rust-blobby" ,rust-blobby-0.3)
+ ("rust-cipher" ,rust-cipher-0.3)
+ ("rust-generic-array" ,rust-generic-array-0.14)
+ ("rust-subtle" ,rust-subtle-2))))
(home-page "https://github.com/RustCrypto/traits")
(synopsis "Trait for Message Authentication Code (MAC) algorithms")
(description "This package provides trait for @dfn{Message Authentication
Code} (MAC) algorithms.")
(license (list license:expat license:asl2.0))))
+(define-public rust-crypto-mac-0.10
+ (package
+ (inherit rust-crypto-mac-0.11)
+ (name "rust-crypto-mac")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "crypto-mac" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "19iyh7h9qaqrv29dhbd31rm6pq023ry78nw7jwr3qjy3l22zsms8"))))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-blobby" ,rust-blobby-0.3)
+ ("rust-cipher" ,rust-cipher-0.2)
+ ("rust-generic-array" ,rust-generic-array-0.14)
+ ("rust-subtle" ,rust-subtle-2))))))
+
(define-public rust-crypto-mac-0.8
(package
(inherit rust-crypto-mac-0.10)
@@ -10927,7 +10948,7 @@ Code} (MAC) algorithms.")
(define-public rust-crypto-mac-0.7
(package
- (inherit rust-crypto-mac-0.8)
+ (inherit rust-crypto-mac-0.10)
(name "rust-crypto-mac")
(version "0.7.0")
(source