summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-03-01 22:51:21 +0100
committerJulien Lepiller <julien@lepiller.eu>2022-03-02 00:11:42 +0100
commit4709a7bb86bd58499e15fbc511c82ae9a32a4037 (patch)
treee8afe40d3a7d3fb0a8bb7e4e7061e02e625b2055
parentf0dbbe88ceaf05a6b7ca12902fbe8d5cd23feae3 (diff)
downloadguix-patches-4709a7bb86bd58499e15fbc511c82ae9a32a4037.tar
guix-patches-4709a7bb86bd58499e15fbc511c82ae9a32a4037.tar.gz
gnu: ocaml-bindlib: Update to 6.0.0.
* gnu/packages/ocaml.scm (ocaml-bindlib): Update to 6.0.0.
-rw-r--r--gnu/packages/ocaml.scm20
1 files changed, 5 insertions, 15 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index bc5d6d4956..bbcb6d887d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4559,30 +4559,20 @@ collection.")
(define-public ocaml-bindlib
(package
(name "ocaml-bindlib")
- (version "5.0.1")
+ (version "6.0.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/rlepigre/ocaml-bindlib")
- (commit (string-append "ocaml-bindlib_" version))))
+ (commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "1f8kr81w8vsi4gv61xn1qbc6zrzkjp8l9ix0942vjh4gjxc74v75"))))
- (build-system ocaml-build-system)
+ "1viyws3igy49hfaj4jaiwm4iggck9zdn7r3g6kh1n4zxphqk57yk"))))
+ (build-system dune-build-system)
(arguments
- `(#:tests? #f ;no tests
- #:use-make? #t
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (replace 'build
- (lambda _
- (invoke "make")))
- (replace 'install
- (lambda _
- (invoke "make" "install"))))))
+ `(#:test-target "."))
(native-inputs
(list ocamlbuild ocaml-findlib))
(home-page "https://rlepigre.github.io/ocaml-bindlib/")