summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-03-01 14:58:08 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-03-01 21:37:38 +0200
commitc835c508a77884e29c1f2e91065d1325584863c6 (patch)
treeb0a9fd04b063aae3a31a2b916d5a2fd2b8d9c0db
parentc67912011154e2b347cdf6f3e633e87fd44f409c (diff)
downloadguix-patches-c835c508a77884e29c1f2e91065d1325584863c6.tar
guix-patches-c835c508a77884e29c1f2e91065d1325584863c6.tar.gz
gnu: guile-3.0-latest: Fix build on powerpc-linux.
* gnu/packages/guile.scm (guile-3.0-latest)[arguments]: On powerpc-linux replace the 'adjust-bootstrap-flags for changes in the source code.
-rw-r--r--gnu/packages/guile.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 6f4afe92cc..328d4506c2 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019 Taylan Kammer <taylan.kammer@gmail.com>
-;;; Copyright © 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 Timothy Sample <samplet@ngyro.com>
;;;
@@ -406,7 +406,19 @@ without requiring the source code to be rewritten.")
;; its multi-stage build process for cross-module inlining, except when
;; cross-compiling.
((#:parallel-build? _ #f)
- (not (%current-target-system)))))))
+ (not (%current-target-system)))
+ ((#:phases phases)
+ `(modify-phases ,phases
+ ,@(if (target-ppc32?)
+ `((replace 'adjust-bootstrap-flags
+ (lambda _
+ ;; Upstream knows about suggested solution.
+ ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=45214
+ ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=977223#46
+ (substitute* "stage0/Makefile.in"
+ (("^GUILE_OPTIMIZATIONS.*")
+ "GUILE_OPTIMIZATIONS = -O1 -Oresolve-primitives -Ocps\n")))))
+ '())))))))
(define-public guile-3.0/fixed
;; A package of Guile that's rarely changed. It is the one used in the