summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcage <cage-dev@twistfold.it>2022-02-26 16:53:57 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-02-26 23:47:53 -0500
commit7eb68770efb33c1444f0ba1654334cfe19b3f5c6 (patch)
treeb73499eb73ac66312147a7e62fb5f524bb5d783d
parent31ecd80db714abfc3ef536b458fc4c1ed778d3c6 (diff)
downloadguix-patches-7eb68770efb33c1444f0ba1654334cfe19b3f5c6.tar
guix-patches-7eb68770efb33c1444f0ba1654334cfe19b3f5c6.tar.gz
gnu: Add gmid.
* gnu/packages/networking.scm (gmid): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/web.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 2a3b67cef3..3faf5bb153 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -55,6 +55,7 @@
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2022 cage <cage-dev@twistfold.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -7836,6 +7837,52 @@ solution for any project's interface needs:
@end itemize\n")
(license license:expat)))
+(define-public gmid
+ (package
+ (name "gmid")
+ (version "1.8.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/omar-polo/gmid/releases/download/"
+ version "/gmid-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0m4809mwy888bqsacmyck68grqfvynq74kswm109al6wjbvd61bn"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:test-target "regress"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (setenv "CC" #$(cc-for-target))
+ (invoke "./configure"
+ (string-append "PREFIX=" #$output)))))))
+ (native-inputs (list bison
+ coreutils
+ flex
+ pkg-config
+ procps
+ which))
+ (inputs (list libevent libressl))
+ (home-page "https://git.omarpolo.com/gmid/about/")
+ (synopsis "Simple and secure Gemini server")
+ (description "@command{gmid} is a fast Gemini server written with security
+in mind. It has features such as:
+@itemize
+@item reload the running configuration without interruption
+@item automatic redirect/error pages
+@item IRI support (RFC3987)
+@item reverse proxying
+@item CGI and FastCGI support
+@item virtual hosts
+@item location rules
+@item event-based asynchronous I/O model
+@item low memory footprint.
+@end itemize")
+ (license license:isc)))
+
(define-public gmnisrv
(package
(name "gmnisrv")