summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-02 19:06:45 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-03 07:47:47 -0400
commit52bd0810a86396e961ca4c92f7e9e5ea0e8c547b (patch)
tree097ee093eda1669a5d5e6c7c0eda2b95c213248f
parentb4f5e0e87c112bd4b8425be0c17524ce9c2a85ca (diff)
downloadguix-patches-52bd0810a86396e961ca4c92f7e9e5ea0e8c547b.tar
guix-patches-52bd0810a86396e961ca4c92f7e9e5ea0e8c547b.tar.gz
gnu: Add postgresql.
* gnu/packages/postgresql.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/postgresql.scm52
2 files changed, 53 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index a3f04ec575..abfb27fade 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -199,6 +199,7 @@ GNU_SYSTEM_MODULES = \
gnu/packages/pkg-config.scm \
gnu/packages/plotutils.scm \
gnu/packages/popt.scm \
+ gnu/packages/postgresql.scm \
gnu/packages/pth.scm \
gnu/packages/pulseaudio.scm \
gnu/packages/pretty-print.scm \
diff --git a/gnu/packages/postgresql.scm b/gnu/packages/postgresql.scm
new file mode 100644
index 0000000000..d6b505f6a2
--- /dev/null
+++ b/gnu/packages/postgresql.scm
@@ -0,0 +1,52 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 David Thompson <davet@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages postgresql)
+ #:use-module ((guix licenses) #:select (x11-style))
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages readline))
+
+(define-public postgresql
+ (package
+ (name "postgresql")
+ (version "9.3.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://ftp.postgresql.org/pub/source/v"
+ version "/postgresql-" version ".tar.gz"))
+ (sha256
+ (base32
+ "08kga00izykgvnx7hn995wc4zjqslspapaa8z63045p1ya14mr4g"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("readline" ,readline)
+ ("zlib" ,zlib)))
+ (home-page "http://www.postgresql.org/")
+ (synopsis "Powerful object-relational database system")
+ (description
+ "PostgreSQL is a powerful object-relational database system. It is fully
+ACID compliant, has full support for foreign keys, joins, views, triggers, and
+stored procedures (in multiple languages). It includes most SQL:2008 data
+types, including INTEGER, NUMERIC, BOOLEAN, CHAR, VARCHAR, DATE, INTERVAL, and
+TIMESTAMP. It also supports storage of binary large objects, including
+pictures, sounds, or video.")
+ (license (x11-style "file://COPYRIGHT"))))