summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-02-23 14:47:06 +0100
committerEfraim Flashner <efraim@flashner.co.il>2022-02-24 12:20:32 +0200
commit38522ff4064d3b9dbfdc032973249d1e0a957e49 (patch)
tree241567e4ae337a08fe488dd1121da91584a1dcfe
parent05d469ab9da077ef2e8e3ada4bd1daee59e31312 (diff)
downloadguix-patches-38522ff4064d3b9dbfdc032973249d1e0a957e49.tar
guix-patches-38522ff4064d3b9dbfdc032973249d1e0a957e49.tar.gz
gnu: julia-media: Use 'julia-package-dependencies'.
* gnu/packages/julia.scm (julia-media)[arguments]: Remove custom phase, add dependency packages to '#:julia-package-dependencies'. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/julia-xyz.scm15
1 files changed, 2 insertions, 13 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 14c8c30751..6bb404761b 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -3508,19 +3508,8 @@ resolving them into absolute units.")
(list
#:julia-package-name "Media"
#:julia-package-uuid "e89f7d12-3494-54d1-8411-f7d8b9ae1f27"
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'create-package-toml
- (lambda* (#:key julia-package-name julia-package-uuid #:allow-other-keys)
- (with-output-to-file "Project.toml"
- (lambda _
- (format #t
- "name = \"~a\"~@
- uuid = \"~a\"~@
- [deps]~@
- MacroTools = \"1914dd2f-81c6-5fcd-8719-6d5c9610ff09\"~%"
- julia-package-name
- julia-package-uuid))))))))
+ #:julia-package-dependencies
+ #~(list '("MacroTools" . "1914dd2f-81c6-5fcd-8719-6d5c9610ff09"))))
(propagated-inputs
(list julia-macrotools))
(home-page "https://github.com/JunoLab/Media.jl")