summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-05-02 13:03:33 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-05-02 13:03:33 +0200
commitfb5b359d7715f85334dd3efdf72512b2a46caa47 (patch)
tree8abda6bc988e80c2fa19c116ed9be07d63825ef8
parent0aa23e02ea7bc51c621b5eee7bd41946239f26a0 (diff)
downloadguix-patches-fb5b359d7715f85334dd3efdf72512b2a46caa47.tar
guix-patches-fb5b359d7715f85334dd3efdf72512b2a46caa47.tar.gz
gnu: inotify-tools: Update to 3.20.1.
* gnu/packages/linux.scm (inotify-tools): Update to 3.20.1. [source]: Download from new home. Set file-name. [native-inputs]: Add AUTOCONF, AUTOMAKE and LIBTOOL. [arguments]: Add 'bootstrap' phase. [home-page]: Update to redirected.
-rw-r--r--gnu/packages/linux.scm20
1 files changed, 15 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4ebdca3b57..228e47437e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1950,17 +1950,27 @@ for systems using the Linux kernel. This includes commands such as
(define-public inotify-tools
(package
(name "inotify-tools")
- (version "3.13")
+ (version "3.20.1")
(source (origin
(method url-fetch)
(uri (string-append
- "mirror://sourceforge/inotify-tools/inotify-tools/"
- version "/inotify-tools-" version ".tar.gz"))
+ "https://github.com/rvoicilas/inotify-tools/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0icl4bx041axd5dvhg89kilfkysjj86hjakc7bk8n49cxjn4cha6"))))
+ "1b22c8x4pjnz3abx4dikpbj43zprjw79pdkd4xw111dsxlfwqcx4"))))
(build-system gnu-build-system)
- (home-page "http://inotify-tools.sourceforge.net/")
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'bootstrap
+ (lambda _
+ (invoke "autoreconf" "-vif"))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (home-page "https://github.com/rvoicilas/inotify-tools/wiki")
(synopsis "Monitor file accesses")
(description
"The inotify-tools packages provides a C library and command-line tools