summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-08 18:57:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-12 14:45:54 +0100
commitf44079bc2151979cde33704fec73f1da1726a2f5 (patch)
tree401492dd0bd5f8f6a1e89edd54505589b66c8520
parentff92c2873c0c8ab9fa6e90020d656aac47dfb088 (diff)
downloadguix-patches-f44079bc2151979cde33704fec73f1da1726a2f5.tar
guix-patches-f44079bc2151979cde33704fec73f1da1726a2f5.tar.gz
gnu: r-rbgl: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-rbgl): Move from here... * gnu/packages/bioconductor.scm (r-rbgl): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm23
-rw-r--r--gnu/packages/bioinformatics.scm23
2 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c698178067..1c298d61cf 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1650,6 +1650,29 @@ high-throughput sequencing experiments.")
the Human Protein Atlas project.")
(license license:artistic2.0)))
+(define-public r-rbgl
+ (package
+ (name "r-rbgl")
+ (version "1.66.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "RBGL" version))
+ (sha256
+ (base32
+ "016vyzgixb3gjpzi21rbs6ngnnqcxr77krwjjf1ldnzzj8vqrqsz"))))
+ (properties `((upstream-name . "RBGL")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bh" ,r-bh)
+ ("r-graph" ,r-graph)))
+ (home-page "https://www.bioconductor.org/packages/RBGL")
+ (synopsis "Interface to the Boost graph library")
+ (description
+ "This package provides a fairly extensive and comprehensive interface to
+the graph algorithms contained in the Boost library.")
+ (license license:artistic2.0)))
+
(define-public r-regioner
(package
(name "r-regioner")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 575158577c..788f780f8d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7387,29 +7387,6 @@ includes software to
")
(license license:cc0))))
-(define-public r-rbgl
- (package
- (name "r-rbgl")
- (version "1.66.0")
- (source
- (origin
- (method url-fetch)
- (uri (bioconductor-uri "RBGL" version))
- (sha256
- (base32
- "016vyzgixb3gjpzi21rbs6ngnnqcxr77krwjjf1ldnzzj8vqrqsz"))))
- (properties `((upstream-name . "RBGL")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-bh" ,r-bh)
- ("r-graph" ,r-graph)))
- (home-page "https://www.bioconductor.org/packages/RBGL")
- (synopsis "Interface to the Boost graph library")
- (description
- "This package provides a fairly extensive and comprehensive interface to
-the graph algorithms contained in the Boost library.")
- (license license:artistic2.0)))
-
(define-public r-gseabase
(package
(name "r-gseabase")