summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2016-05-04 15:55:23 +0200
committerLeo Famulari <leo@famulari.name>2016-05-05 20:23:48 -0400
commit82047474ea4913ca0a67da410fcb2622c82afa14 (patch)
tree5754d1fa6990aaf783dac7f62d4c5d00e6471043
parent76192896e9fa9a79e76752b60b96a911a3e632ee (diff)
downloadguix-patches-82047474ea4913ca0a67da410fcb2622c82afa14.tar
guix-patches-82047474ea4913ca0a67da410fcb2622c82afa14.tar.gz
gnu: Add r-coda.
* gnu/packages/statistics.scm (r-coda): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/statistics.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 3d0faf7572..a362b32478 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Pjotr Prins <pjotr.guix@thebird.nl>
+;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1239,6 +1240,27 @@ inference for statistical models.")
`(("python2-setuptools" ,python2-setuptools)
,@(package-native-inputs stats))))))
+(define-public r-coda
+ (package
+ (name "r-coda")
+ (version "0.18-1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "coda" version))
+ (sha256
+ (base32
+ "03sc780734zj2kqcm8lkyvf76fql0jbfhkblpn8l58zmb6cqi958"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-lattice" ,r-lattice)))
+ (home-page "http://cran.r-project.org/web/packages/coda")
+ (synopsis "This is a package for Output Analysis and Diagnostics for MCMC")
+ (description "This package provides functions for summarizing and plotting
+the output from Markov Chain Monte Carlo (MCMC) simulations, as well as
+diagnostic tests of convergence to the equilibrium distribution of the Markov
+chain.")
+ (license license:gpl2+)))
+
(define-public r-xml2
(package
(name "r-xml2")