summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-13 10:51:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-13 10:51:41 +0100
commit6018683683ac49765ee0eda4cb09606f1d3689fe (patch)
treea338eeb108dbbce13c0cd7f8e35cdc48390c7450
parent7fed5481fe4029e4f85d90ee163a0fb1c5d617f5 (diff)
downloadguix-patches-6018683683ac49765ee0eda4cb09606f1d3689fe.tar
guix-patches-6018683683ac49765ee0eda4cb09606f1d3689fe.tar.gz
gnu: c-toxcore: Fetch sources from git.
* gnu/packages/messaging.scm (c-toxcore)[source]: Fetch from git.
-rw-r--r--gnu/packages/messaging.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index a7b868ccc0..c22cacfd36 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -860,13 +860,14 @@ protocols.")
(version "0.2.8")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/TokTok/c-toxcore/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/TokTok/c-toxcore.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0qlkimlvbd24nlj7w9b5rpz1r807magqxmfylc1mlxsqhmfi5zj7"))))
+ "0xgnraysz25fbws5zwjk92mwnl8k1yih701qam8kgm3rxh50kyhm"))))
(arguments
`(#:tests? #f)) ; FIXME: Testsuite seems to stay stuck on test 3. Disable
; for now.