summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-05 12:45:18 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-05 15:04:02 +0100
commita8b60bd475808776629502e16a9fcf7292ef0fe3 (patch)
tree3bf5573b6e6d0857d08ac3b1afac3f9c6fda37d3
parent4c6cb448fdd79a446819c410a26342fd105737d4 (diff)
downloadguix-patches-a8b60bd475808776629502e16a9fcf7292ef0fe3.tar
guix-patches-a8b60bd475808776629502e16a9fcf7292ef0fe3.tar.gz
gnu: sjcount: Remove reference to %build-inputs.
* gnu/packages/bioinformatics.scm (sjcount)[arguments]: Remove reference to %build-inputs by using a gexp.
-rw-r--r--gnu/packages/bioinformatics.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 95b4ca1b78..925a1a549d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11369,9 +11369,9 @@ analyses in addition to large-scale sequence-level searches.")
(arguments
`(#:tests? #f ; requires a 1.4G test file
#:make-flags
- (list (string-append "SAMTOOLS_DIR="
- (assoc-ref %build-inputs "samtools")
- "/lib/"))
+ ,#~(list (string-append "SAMTOOLS_DIR="
+ #$(this-package-input "samtools")
+ "/lib/"))
#:phases
(modify-phases %standard-phases
(replace 'configure